Bug 1656334 - [cloud-CA] machineautoscaler setting maxReplicas equal to minReplicas will result in "group size not found"
Summary: [cloud-CA] machineautoscaler setting maxReplicas equal to minReplicas will re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Andrew McDermott
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 09:24 UTC by sunzhaohua
Modified: 2019-06-04 10:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:10 UTC

Description sunzhaohua 2018-12-05 09:24:12 UTC
Description of problem:
Setting maxReplicas equal to minReplicas, will result in "group size not found".

Version-Release number of selected component (if applicable):
$ bin/openshift-install version
bin/openshift-install v0.5.0-master-2-g78e2c8b144352b1bef854501d3760a9daaaa2eb0
Terraform v0.11.8

How reproducible:
Always

Steps to Reproduce:
1. Create clusterautoscaler resource
2. Create machineautoscaler resource, set maxReplicas=2, minReplicas=2
3. Create pod to scale up the cluster
4. Check logs

Actual results:
Logs output "group size not found"

$ oc get machineautoscaler autoscale-us-east-2a-85rjb -o yaml
apiVersion: autoscaling.openshift.io/v1alpha1
kind: MachineAutoscaler
metadata:
  creationTimestamp: 2018-12-04T04:50:03Z
  finalizers:
  - machinetarget.autoscaling.openshift.io
  generateName: autoscale-us-east-2a-
  generation: 1
  name: autoscale-us-east-2a-85rjb
  namespace: openshift-cluster-api
  resourceVersion: "193797"
  selfLink: /apis/autoscaling.openshift.io/v1alpha1/namespaces/openshift-cluster-api/machineautoscalers/autoscale-us-east-2a-85rjb
  uid: 102eed94-f780-11e8-ba7f-0644519597a8
spec:
  maxReplicas: 2
  minReplicas: 2
  scaleTargetRef:
    apiVersion: cluster.k8s.io/v1alpha1
    kind: MachineSet
    name: qe-zhsun-worker-us-east-2a
status: {}

$ oc logs -f cluster-autoscaler-default-77f884d74b-527bq
E1204 08:26:01.996252       1 utils.go:467] Error while checking node group size qe-zhsun-worker-us-east-2a: group size not found
E1204 08:26:01.996545       1 utils.go:467] Error while checking node group size qe-zhsun-worker-us-east-2b: group size not found
E1204 08:26:01.996678       1 utils.go:467] Error while checking node group size qe-zhsun-worker-us-east-2c: group size not found


Expected results:
Cluster can scale up and allow some group has fixed node number.


Additional info:

Comment 1 Andrew McDermott 2019-02-22 16:10:20 UTC
PR - https://github.com/openshift/kubernetes-autoscaler/pull/42

Comment 2 sunzhaohua 2019-02-26 03:10:05 UTC
Verified.

The misleading messages has been removed from the autoscaler logs.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-02-25-234632   True        False         32m       Cluster version is 4.0.0-0.nightly-2019-02-25-234632

Comment 5 errata-xmlrpc 2019-06-04 10:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.