Bug 1656353 - Extra options in `Show at Login` in Visual tab of My Settings and long wait for the effect to take place
Summary: Extra options in `Show at Login` in Visual tab of My Settings and long wait f...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Parthvi Vala
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 10:12 UTC by Parthvi Vala
Modified: 2018-12-05 21:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-05 14:49:28 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Parthvi Vala 2018-12-05 10:12:33 UTC
Description of problem:
There are 4 problems here:
1. Take a fresh appliance, the first page that you see on login is `Compute/Infrastructure/Providers`, even though the options selected in `Show at login` is `Cloud Intel / Dashboard`.

2. There are extra options available in `Show at Login` drop-down in the Visual tab of My Settings.

3. There is no option related to Physical Provider pages available in the drop-down list.

4. Changing the `Show at Login` page takes a lot of time to come into effect, probably 4-5 minutes, this time could be reduced to take effect immediately.

Version-Release number of selected component (if applicable):
5.9.2.4

How reproducible:
Always

Steps to Reproduce:
1. Take a fresh appliance and login. (The first page you see is `Compute / Infrastructure / Providers`.)
2. Navigate to My Settings > Visual(Tab) > Start Page(Section)
3. Observe the value selected in `Show at Login`. (It's `Cloud Intel / Dashboard`, even though the page we encountered on login was not it.)
4. Check all the options available in `Start Page` dropdown.
5. Select any option, say `Cloud Intel / Reports` and save the settings.
6. Logout and login immediately. 

Actual results:
1. The value of `Show at Login` is `Cloud Intel / Dashboard` even though the page we encountered on login was `Compute / Infrastructure / Providers`.
2. Extra options (such as: Middleware / *, Consumption / Dashboard, Compute / Migration, Datawarehouse / Providers) available, even though those pages are not available for navigation.
3. Options such as `Physical Provider / *` not available in the list.
4. Once the value of `Show at Login` is set, it takes about 4-5 minutes for that effect to take place.

Expected results:
1. Value of `Show at Login` must correspond to the page that user sees on logging.
2. Extra options must be removed from the drop-down list since those pages are no longer available.
3. Options such as `Physical Provider / *` must be available in the dropdown list.
4. It should not take too long to see the new start page, that change must take place immediately.


Additional info:
Setting the value of `Show at Login` to any of the above-mentioned options does not break anything. If any of the above-mentioned options are selected, then `Compute / Infrastructure / Providers` page will be loaded instead.

Problems 1, 3 and 4 persists on 5.10 as well. 5.10 also misses one option `Storage / Block Storage / Volume Types`, that option needs to be added to the list.

There is one more option `Monitor / Alerts / Most Recent Alerts` which seems extra. If this option is selected, user will land on a page that shows most recent alerts, but user cannot navigate to this page on will, I didn't find any way to reach this page.

Comment 4 dmetzger 2018-12-05 14:49:28 UTC
Please open 4 individual tickets, one for each issue.


Note You need to log in before you can comment on or make changes to this bug.