Bug 165639 - vim-X11-6.3.086-0.fc3 requires gtk2 >= 2.6 but only gtk2-2.4 is provided
vim-X11-6.3.086-0.fc3 requires gtk2 >= 2.6 but only gtk2-2.4 is provided
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-08-10 20:56 EDT by Bill Dripps
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-11 10:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Dripps 2005-08-10 20:56:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
'yum update" would like to update my system with vim-X11-6.3.086-0.fc3, but it reequire gtk2-2.6 which is not available for FC3. My guess is that vim-X11 should be rebuilt against gtk2-2.4 for FC3.


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.yum update

Actual Results:  ---> Package vim-X11.i386 1:6.3.086-0.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: gtk2 >= 2.6 for package: vim-X11
--> Finished Dependency Resolution
Error: Missing Dependency: gtk2 >= 2.6 is needed by package vim-X11

Expected Results:  Complete!

Additional info:
Comment 1 Michael Sinz 2005-08-10 23:30:41 EDT
The problem is that the vim.spec file calls out for gtk2 >= 2.6 but it does not
need it.  In fact, the spec file builds just fine on a standard FC3 machine
(gtk2 2.4.x) but the resulting RPM fails due to this check!

If you "rpm --nodeps" the file it will install and run just fine.

See line 229 of the vim.spec file.

As far as I can tell, it should not require gtk2 >= 2.6 in atleast the FC3
builds and it would be even better if the spec file defined the dependancy to be
that of the version built against. (Maybe?)

Just change the 2.6 to 2.4 and rebuild the binary RPMs and then you would not
need to use the "--nodeps" option.
Comment 2 Karsten Hopp 2005-08-11 05:10:02 EDT
Yes, leaving the hard requirement was an oversight. It's already fixed in
6.3.086-0.fc3.1 in the testing tree. If you can confirm that it works (even
gvim), I'll move it over to final.
Comment 3 Bill Dripps 2005-08-11 07:42:36 EDT
vim-X11-6.3.086-0.fc3.1.i386.rpm and vim-common-6.3.086-0.fc3.1.i386.rpm from
testing installed and gvim at least started up and edited one file correctly.

But, vim-enhanced would not install at the same time because it wanted
vim-common = 1:6.3.086-0.fc3. This meant that vim and vi were not installed. 

So, it looks to me like all three (vim-common, vim-X11 and vim-enhanced) need to
be updated as a set.
Comment 4 Bill Dripps 2005-08-11 07:53:45 EDT
It looks ok now.

I installed vim-X11.i386 1:6.3.086-0.fc3.1 vim-common.i386 1:6.3.086-0.fc3.1 and
vim-enhanced.i386 1:6.3.086-0.fc3.1 together with no problems. Gvim vim and vi
all see to work. 

I see no further problem.
Comment 5 Karsten Hopp 2005-08-11 10:29:24 EDT
Thanks for testing...
I've moved the package from -testing to -final

Note You need to log in before you can comment on or make changes to this bug.