Bug 165642 - Running 'yum update' on FC3 after clean install. After 'Downloading Packages' and 'Running Transaction Test' it quits out with a ***glibc detected *** double free or corruption: 0x00cda848 error
Running 'yum update' on FC3 after clean install. After 'Downloading Packages'...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 21:26 EDT by A. Easton
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-11 11:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Easton 2005-08-10 21:26:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
As in summary, all goes well until yum crashes out with the glibc error. 
Attempted update of yum, same error.
Attempted update of glibc, same error.
Dropped run-level to 3, rebooted.
Attempted system update again... Awaiting results (0227hrs UTC)

Version-Release number of selected component (if applicable):
yum-2.2.2-0.fc3

How reproducible:
Always

Steps to Reproduce:
1.yum -C update
2.OR yum update
3.OR yum update PKGNAME
  

Actual Results:  glibc detected error, as stated in summary.

Expected Results:  Package updating.

Additional info:

System in question is a 1.3 Duron (*Wince*). 256SDram. 80gbHDD. Plenty of space. TOP reports no excessive memory usage or CPU usage. All seems to be running okay up until the error.

Will give more information as I can. Performing all this remotely, so have limited information, but this error occoured six or seven times in a row.
Comment 1 Jeremy Katz 2005-08-10 21:57:26 EDT
It happens when updating any single package?  Can you run yum with -d6 and
provide the output?
Comment 2 A. Easton 2005-08-10 22:47:19 EDT
I will, as soon as able. It's still running the attempted update after runlevel
change. It's a clean install, so it's a lot of updating. If this works, then
obviously it was probably an oddity related to the machine, but I'll update you
as soon as I have information.
Comment 3 A. Easton 2005-08-11 11:39:30 EDT
Okay. Update as follows... After rebooting, YUM completed it's update fine, with
no errors relating to this bug.

I can therefore only assume it was an isolated (Although repeatable) issue,
which was resolved by a reboot of the system.

Going to close issue as NOTABUG, as this really does appear to be an isolated
incident.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.