Bug 1656429 - iperf3: option --udp-counters-64bit shown in --help output but not in man page
Summary: iperf3: option --udp-counters-64bit shown in --help output but not in man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: iperf3
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.0
Assignee: Michal Ruprich
QA Contact: Patrik Moško
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 13:52 UTC by Patrik Moško
Modified: 2020-11-04 02:29 UTC (History)
2 users (show)

Fixed In Version: iperf3-3.5-4.el8
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 02:28:53 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Patch (747 bytes, patch)
2020-02-17 09:33 UTC, Michal Ruprich
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4621 0 None None None 2020-11-04 02:28:56 UTC

Description Patrik Moško 2018-12-05 13:52:37 UTC
Description of problem:
echo $Summary

NVR:   iperf3-3.5-2.el8

How reproducible:  always

Steps to reproduce:
1. man iperf3| cat |grep udp-counters-64bit
2. iperf3 -h | grep udp-counters-64bit

Actual results:
1. (no output)
2.  --udp-counters-64bit      use 64-bit counters in UDP test packets

Expected results:
1.       --udp-counters-64bit
2.  --udp-counters-64bit      use 64-bit counters in UDP test packets

Note:
docs for '--udp-counters-64bit' has been posted in upstream already.
https://github.com/esnet/iperf/pull/796/commits/f090bd4b74500f756179aab009998b0d5c1a2668

Comment 1 Michal Ruprich 2020-02-17 09:33:24 UTC
Created attachment 1663475 [details]
Patch

Comment 11 errata-xmlrpc 2020-11-04 02:28:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (iperf3 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4621


Note You need to log in before you can comment on or make changes to this bug.