Bug 1656439 - PVs get stuck when the user deletes the project
Summary: PVs get stuck when the user deletes the project
Keywords:
Status: CLOSED DUPLICATE of bug 1626683
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.11.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Hemant Kumar
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 14:05 UTC by Gabor Burges
Modified: 2019-01-04 17:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-04 17:46:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gabor Burges 2018-12-05 14:05:15 UTC
Description of problem:
When the user deletes a whole project, a lot of times the PVs get into a Failed state with
  Warning  VolumeFailedDelete  51m   persistentvolume-controller  Error deleting EBS volume <volume> since volume is currently attached to <node>


Version-Release number of selected component (if applicable):
openshift v3.11.43
kubernetes v1.11.0+d4cacc0
compute nodes use m5.2xlarge sizes

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
volume fails to delete, gets stuck in 'Failed' state

Expected results:
volume detaches and deletes cleanly

Master Log:

Node Log (of failed PODs):

PV Dump:


PVC Dump:
project was deleted
 
StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 5 Hemant Kumar 2019-01-04 17:46:23 UTC
This is same as https://bugzilla.redhat.com/show_bug.cgi?id=1626683 . Fixing nvme driver should fix this issue. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 1626683 ***


Note You need to log in before you can comment on or make changes to this bug.