Bug 1656462 - [abrt] gnome-software: g_hash_table_resize(): gnome-software killed by SIGABRT
Summary: [abrt] gnome-software: g_hash_table_resize(): gnome-software killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8da2d77f17c78c5b502db1efcd9...
: 1660419 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 15:11 UTC by Guy Streeter
Modified: 2018-12-22 03:02 UTC (History)
3 users (show)

Fixed In Version: gnome-software-3.30.6-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-22 03:02:15 UTC


Attachments (Terms of Use)
File: backtrace (66.96 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: cgroup (195 bytes, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: core_backtrace (38.76 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: cpuinfo (1.15 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: dso_list (17.10 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: environ (3.52 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: limits (1.29 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: maps (111.16 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: mountinfo (4.05 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: open_fds (4.64 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: proc_pid_status (1.32 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details
File: var_log_messages (1.80 KB, text/plain)
2018-12-05 15:11 UTC, Guy Streeter
no flags Details

Description Guy Streeter 2018-12-05 15:11:31 UTC
Version-Release number of selected component:
gnome-software-3.30.5-1.fc29

Additional info:
reporter:       libreport-2.9.6
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: g_hash_table_resize
executable:     /usr/bin/gnome-software
journald_cursor: s=4cfda5c0249b4a2186834073b4aaa70d;i=757c;b=308874d09c714eb099a195c8498a8a6a;m=1243674e5;t=57c477d0ce1e1;x=f806d02f7ca05adf
kernel:         4.19.5-300.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1001

Potential duplicate: bug 1053406

Comment 1 Guy Streeter 2018-12-05 15:11:34 UTC
Created attachment 1511746 [details]
File: backtrace

Comment 2 Guy Streeter 2018-12-05 15:11:35 UTC
Created attachment 1511747 [details]
File: cgroup

Comment 3 Guy Streeter 2018-12-05 15:11:37 UTC
Created attachment 1511748 [details]
File: core_backtrace

Comment 4 Guy Streeter 2018-12-05 15:11:37 UTC
Created attachment 1511749 [details]
File: cpuinfo

Comment 5 Guy Streeter 2018-12-05 15:11:39 UTC
Created attachment 1511750 [details]
File: dso_list

Comment 6 Guy Streeter 2018-12-05 15:11:40 UTC
Created attachment 1511751 [details]
File: environ

Comment 7 Guy Streeter 2018-12-05 15:11:40 UTC
Created attachment 1511752 [details]
File: limits

Comment 8 Guy Streeter 2018-12-05 15:11:42 UTC
Created attachment 1511753 [details]
File: maps

Comment 9 Guy Streeter 2018-12-05 15:11:43 UTC
Created attachment 1511754 [details]
File: mountinfo

Comment 10 Guy Streeter 2018-12-05 15:11:44 UTC
Created attachment 1511755 [details]
File: open_fds

Comment 11 Guy Streeter 2018-12-05 15:11:45 UTC
Created attachment 1511756 [details]
File: proc_pid_status

Comment 12 Guy Streeter 2018-12-05 15:11:46 UTC
Created attachment 1511757 [details]
File: var_log_messages

Comment 13 Kalev Lember 2018-12-05 15:25:10 UTC
Looks like missing locking in the odrs plugin. This is already fixed upstream and the fix should be included in the upcoming gnome-software 3.30.6 release.

Comment 14 aoellerer 2018-12-18 10:03:01 UTC
*** Bug 1660419 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2018-12-19 03:36:45 UTC
PackageKit-1.1.12-2.fc29, gnome-software-3.30.6-1.fc29, libappstream-glib-0.7.14-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e0db56c00c

Comment 16 Fedora Update System 2018-12-22 03:02:15 UTC
PackageKit-1.1.12-2.fc29, gnome-software-3.30.6-1.fc29, libappstream-glib-0.7.14-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.