Bug 1656468 - ceph-ansible: call ceph-volume command during 4.x upgrade to port ceph-disk osds to ceph-volume
Summary: ceph-ansible: call ceph-volume command during 4.x upgrade to port ceph-disk o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Ameena Suhani S H
QA Contact: Ameena Suhani S H
Bara Ancincova
URL:
Whiteboard:
: 1652837 (view as bug list)
Depends On: 1656460 1790212
Blocks: 1656454 1730176 1770263
TreeView+ depends on / blocked
 
Reported: 2018-12-05 15:16 UTC by Andrew Schoen
Modified: 2020-04-08 17:00 UTC (History)
13 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc7.el8cp
Doc Type: Enhancement
Doc Text:
.Ceph OSDs created with `ceph-disk` are migrated to `ceph-volume` during upgrade When upgrading to {product} 4, all running Ceph OSDs previously created by the `ceph-disk` utility will be migrated to the `ceph-volume` utility because `ceph-disk` has been deprecated in this release. For bare-metal and container deployments of {product}, the `ceph-volume` utility does a simple scan and takes over the existing Ceph OSDs deployed by the `ceph-disk` utility. Also, do not use these migrated devices in configurations for subsequent deployments. Note that you cannot create any new Ceph OSDs during the upgrade process. After the upgrade, all Ceph OSDs created by `ceph-disk` will start and operate like any Ceph OSDs created by `ceph-volume`.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:45:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3727 0 None closed rolling_update: migrate ceph-disk osds to ceph-volume 2020-09-23 01:16:55 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:44 UTC

Description Andrew Schoen 2018-12-05 15:16:24 UTC
ceph-ansible should handle the automation to call the ceph-volume command to be defined in https://bugzilla.redhat.com/show_bug.cgi?id=1656460 to port all existing ceph-disk osds to ceph-volume on upgrade.

Comment 1 Sébastien Han 2019-02-26 16:41:17 UTC
*** Bug 1652837 has been marked as a duplicate of this bug. ***

Comment 5 Giridhar Ramaraju 2019-08-05 13:06:48 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 6 Giridhar Ramaraju 2019-08-05 13:09:24 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 13 errata-xmlrpc 2020-01-31 12:45:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.