Bug 1656486 - [RFE] GlusterFS version check in installer
Summary: [RFE] GlusterFS version check in installer
Keywords:
Status: CLOSED DUPLICATE of bug 1499035
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Jose A. Rivera
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 15:41 UTC by Jose A. Rivera
Modified: 2018-12-06 13:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-06 13:11:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jose A. Rivera 2018-12-05 15:41:14 UTC
For enterprise installations, there should be some mechanism that checks that a user is specifying an explicit version for all OCS container images. It is not simple (nor technically correct) to provide any numbered default to an OCS version per version of openshift-ansible. The only reasonable alternative would be to specify NO default, and require the user to manually specify an explicit version every time (if certain conditions are met, e.g. gluster node groups are defined).

Comment 1 Jose A. Rivera 2018-12-05 15:42:22 UTC
Michael, can you provide any pointers about where this check should be implemented?

Comment 2 Michael Gugino 2018-12-05 15:57:02 UTC
I would put it in https://github.com/openshift/openshift-ansible/blob/release-3.11/playbooks/init/sanity_checks.yml

We run that during installs and upgrades.  Gluster-specific plays probably run it as well; this will allow the install/upgrade to fail early.

Comment 3 Jose A. Rivera 2018-12-06 13:11:55 UTC
It'd help if I searched for duplicates first. :)

*** This bug has been marked as a duplicate of bug 1499035 ***


Note You need to log in before you can comment on or make changes to this bug.