Bug 1656494 - warn users during upgrade of existing ceph-disk OSDs
Summary: warn users during upgrade of existing ceph-disk OSDs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Volume
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Alfredo Deza
QA Contact: Parikshith
URL:
Whiteboard:
Depends On: 1656460
Blocks: 1656454
TreeView+ depends on / blocked
 
Reported: 2018-12-05 16:07 UTC by Andrew Schoen
Modified: 2019-06-11 21:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 21:19:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew Schoen 2018-12-05 16:07:51 UTC
During an upgrade to 4.0 warn users if there are existing ceph-disk OSDs. This should be done in the packaging so if a user upgrades manually they'll notice and can be directed to run the proper ceph-volume command to migrate these OSDs.

Comment 1 Andrew Schoen 2019-06-11 21:19:18 UTC
We decided against doing anything in the packaging in relation to ceph-disk upgrades to ceph-volume.


Note You need to log in before you can comment on or make changes to this bug.