Bug 1656591 - Integrate ceph-dashboard into Ceph-Ansible
Summary: Integrate ceph-dashboard into Ceph-Ansible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Zack Cerza
QA Contact: Sunil Angadi
Aron Gunn
URL:
Whiteboard:
: 1563009 (view as bug list)
Depends On:
Blocks: 1760354 1475556 1642481 1730176 1806495
TreeView+ depends on / blocked
 
Reported: 2018-12-05 19:24 UTC by Ernesto Puerta
Modified: 2020-04-01 10:26 UTC (History)
14 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc8.el8cp
Doc Type: Enhancement
Doc Text:
.Ceph dashboard has been added to the Ceph Ansible playbooks With this release, the Ceph dashboard installation code was merged into the Ceph Ansible playbooks. Ceph Ansible does a containerized deployment of the Ceph dashboard regardless of the {storage-product} deployment type, bare metal or containers. These four new roles were added: `ceph-grafana`, `ceph-dashboard`, `ceph-prometheus` and `ceph-node-exporter`.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:45:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3426 0 'None' closed Merge dashboard-ansible code into ceph-ansible 2020-09-22 14:43:23 UTC
Github ceph ceph-container pull 1290 0 'None' closed daemon-base: Add ceph-grafana-dashboards 2020-09-22 14:43:23 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:11 UTC

Description Ernesto Puerta 2018-12-05 19:24:33 UTC
Customer should have a single installation workflow for a new cluster that incorporates the deployment of dashboard and monitoring.

Currently Ceph-dasboard + Prometheus + Node Exporter + Grafana are deployed with Cephmetrics Ansible playbook (https://github.com/ceph/cephmetrics/tree/wip-dashboard). 4.0 will also include Alertmanager (https://github.com/ceph/cephmetrics/tree/wip-alertmanager), and perhaps a SSO (Keycloak).

This should be expected to be integrated into Ceph-Ansible playbooks.

Comment 3 Ernesto Puerta 2018-12-18 19:40:55 UTC
Related to Bug #1656591

Comment 4 Ernesto Puerta 2018-12-18 19:43:22 UTC
(In reply to Ernesto Puerta from comment #3)
> Related to Bug #1656591

That head of mine... Bug #1563009

Comment 10 Christina Meno 2019-02-27 23:26:59 UTC
*** Bug 1563009 has been marked as a duplicate of this bug. ***

Comment 27 errata-xmlrpc 2020-01-31 12:45:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.