Bug 1656631 - gnucash appdata missing
Summary: gnucash appdata missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 22:03 UTC by Rex Dieter
Modified: 2018-12-26 00:39 UTC (History)
3 users (show)

Fixed In Version: gnucash-3.3-2.fc29 gnucash-2.6.21-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-15 03:18:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Rex Dieter 2018-12-05 22:03:51 UTC
While gnucash includes an appdata file, it appears that is being rejected and not included in fedora repo metadata.

Users are reporting it's not available from gnome-software/PackageKit, and I just confirmed using
appstreamcli search gnucash
got one indirect result for skrooge application, and nothing for gnucash itself.

This may offer a clue:
https://dl.fedoraproject.org/pub/alt/screenshots/f29/failed.html

mentions:
Vetos	Has no Icon

not sure why exactly, gnucash does indeed include an application icons named: gnucash-icon.png.

Comment 1 Kalev Lember 2018-12-06 07:29:41 UTC
Looks like gnucash appdata file includes an invalid reference to the desktop file, so it fails to find any information that the desktop file provides (icon etc).

Comment 2 Kalev Lember 2018-12-06 08:32:26 UTC
Upstream PR: https://github.com/Gnucash/gnucash/pull/440

Comment 3 Fedora Update System 2018-12-06 13:28:43 UTC
gnucash-2.6.21-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-86f0abc677

Comment 4 Fedora Update System 2018-12-06 13:28:47 UTC
gnucash-3.3-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f43a91a7e8

Comment 5 Fedora Update System 2018-12-06 13:28:52 UTC
gnucash-3.3-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-40a0ed580c

Comment 6 Bill Nottingham 2018-12-07 02:22:28 UTC
Thanks for taking care of this!

Comment 7 Fedora Update System 2018-12-07 03:15:58 UTC
gnucash-3.3-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-40a0ed580c

Comment 8 Fedora Update System 2018-12-07 03:22:31 UTC
gnucash-3.3-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f43a91a7e8

Comment 9 Fedora Update System 2018-12-07 03:56:35 UTC
gnucash-2.6.21-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-86f0abc677

Comment 10 Fedora Update System 2018-12-15 03:18:53 UTC
gnucash-3.3-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-12-26 00:39:17 UTC
gnucash-2.6.21-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.