Bug 165668 - slides don't get marked for save when doing a spelling correction
slides don't get marked for save when doing a spelling correction
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 06:03 EDT by Brian Stein
Modified: 2013-03-01 00:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 08:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 53208 None None None Never

  None (edit)
Description Arjan van de Ven 2005-08-11 06:03:58 EDT
Description of problem:

when the user uses the right-click menu item to correct a spelling mistake, the
document doesn't get marked for saving (eg the save button remains gray) and
thus the modification can get lost


Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.112-1.1.0.fc4

How reproducible:
always

Steps to Reproduce:
1. create a slide with a spelling mistake in it
2. save the slide
3. use the right click menu to correct the spelling mistake

  
Actual results:
toolbar save button is grayed out

Expected results:
toolbar save button should have been activated

Additional info:
Comment 1 Caolan McNamara 2005-08-11 06:36:03 EDT
editengine only, i.e. writer does the right thing. Clicking outside the textbox
will enable the "unsaved changes" icon, presumably more editengine stupidity.
Comment 2 Caolan McNamara 2005-08-15 08:03:19 EDT
This (as usual with the pointless editengine) is totally hosed, the only
modifications checked during editing are the actual keypresses because they're
intercepted and fed through to the editengine and changes checked there and the
modification set. Any other modification state is uncheckable until deactivated
and commited to the document, bold/italic etc etc don't set the "save me" icon
state. No quick fix. 

Note You need to log in before you can comment on or make changes to this bug.