Bug 1656733 - [OSP13] After a staggered OC reboot rabbitmq fails to get clustered
Summary: [OSP13] After a staggered OC reboot rabbitmq fails to get clustered
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents
Version: 7.6
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Oyvind Albrigtsen
QA Contact: pkomarov
URL:
Whiteboard:
Depends On: 1575095
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 08:13 UTC by RAD team bot copy to z-stream
Modified: 2019-04-23 16:52 UTC (History)
19 users (show)

Fixed In Version: resource-agents-4.1.1-12.el7_6.8
Doc Type: Bug Fix
Doc Text:
Previously, the rabbitmq server sometimes failed to start on some cluster nodes. This happened because rabbitmq failed to get clustered if nodes from the node list became unavailable while another node was joining the cluster. With this update, the resource is given more time to start by retrying the entire start action until it succeeds or until the start timeout is reached. As a result, the described problem no longer occurs.
Clone Of: 1575095
Environment:
Last Closed: 2019-03-13 18:45:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3990761 Troubleshoot None Regression in resource-agents 4.1.1-12.el7_6.6 causes rabbitmq-bundle failures after certain restarts 2019-04-23 16:52:49 UTC
Red Hat Product Errata RHBA-2019:0499 None None None 2019-03-13 18:45:05 UTC

Description RAD team bot copy to z-stream 2018-12-06 08:13:50 UTC
This bug has been copied from bug #1575095 and has been proposed to be backported to 7.6 z-stream (EUS).

Comment 4 pkomarov 2019-01-28 11:10:36 UTC
Verified via automation: 
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/upgrades/view/update/job/DFG-upgrades-updates-13-from-z3-composable-ipv6/7/artifact/.sh/ir-tripleo-overcloud-reboot.log

section : 

TASK [check for any stopped pcs resources] *************************************
task path: /home/rhos-ci/jenkins/workspace/DFG-upgrades-updates-13-from-z3-composable-ipv6/infrared/plugins/tripleo-overcloud/overcloud_reboot.yml:208
Sunday 27 January 2019  16:04:23 +0000 (0:00:00.056)       0:16:07.014 ******** 
[DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using 
`result|failed` use `result is failed`. This feature will be removed in version
 2.9. Deprecation warnings can be disabled by setting 
deprecation_warnings=False in ansible.cfg.
 [WARNING]: when statements should not include jinja2 templating delimiters
such as {{ }} or {% %}. Found: '{{ install.deployment.files | basename }}' ==
'virt'

skipping: [messaging-1] => (item=Stopped)  => {
    "changed": false, 
    "item": "Stopped", 
    "skip_reason": "Conditional result was False"
}
skipping: [messaging-1] => (item=Starting)  => {
    "changed": false, 
    "item": "Starting", 
    "skip_reason": "Conditional result was False"
}
skipping: [messaging-1] => (item=Promoting)  => {
    "changed": false, 
    "item": "Promoting", 
    "skip_reason": "Conditional result was False"
}

Comment 6 errata-xmlrpc 2019-03-13 18:45:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0499


Note You need to log in before you can comment on or make changes to this bug.