Bug 1656734 - The "All Ansible Tower Templates" view in the Tower provider also shows embedded Ansible templates
Summary: The "All Ansible Tower Templates" view in the Tower provider also shows embed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.11.0
Assignee: Harpreet Kataria
QA Contact: Satyajit Bulage
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 08:15 UTC by Peter McGowan
Modified: 2020-01-23 14:27 UTC (History)
9 users (show)

Fixed In Version: 5.11.0.18
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-12 13:34:53 UTC
Category: ---
Cloudforms Team: Ansible
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing Tower templates (218.11 KB, image/png)
2018-12-06 08:15 UTC, Peter McGowan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4199 None None None 2019-12-12 13:35:08 UTC

Description Peter McGowan 2018-12-06 08:15:41 UTC
Created attachment 1511991 [details]
Screenshot showing Tower templates

Description of problem:
The "All Ansible Tower Templates" view in the Tower provider details also erroneously shows templates defined for the embedded Ansible provider as a result of creating playbook services.

Version-Release number of selected component (if applicable):
5.10.0.27

How reproducible:
Every time

Steps to Reproduce:
1. Enable the Embedded Ansible server role, add a repository.
2. Create a playbook service using an embedded Ansible playbook
3. Add an Ansible Tower provider that has some job templates defined.

Actual results:
In the CloudForms display for the Tower provider job templates, observe both the embedded Ansible templates from the defined services, and the correct Tower provider templates are shown. The Accordian only shows the correct Tower templates (see attached screenshot).

Expected results:
Only the templates defined in the external Tower provider should be listed.

Additional info:

Comment 3 Harpreet Kataria 2019-08-01 15:32:15 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/5925

Comment 4 CFME Bot 2019-08-02 08:56:49 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/1b9685720615c82789d8cf3744b691cc6ef80c32
commit 1b9685720615c82789d8cf3744b691cc6ef80c32
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Aug  1 11:29:18 2019 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Aug  1 11:29:18 2019 -0400

    Changed model name when showing list of Tower Templates.

    previously code was passing in model as `ConfigurationScript` that returns all Tower templates, Changed to use `ManageIQ::Providers::AnsibleTower::AutomationManager::ConfigurationScript` so that embedded ansible templates are excluded from the list

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1656734

 app/controllers/automation_manager_controller.rb | 4 +-
 product/views/ManageIQ_Providers_AnsibleTower_AutomationManager_ConfigurationScript.yaml | 82 +
 spec/controllers/automation_manager_controller_spec.rb | 2 +-
 3 files changed, 85 insertions(+), 3 deletions(-)

Comment 5 CFME Bot 2019-08-02 16:12:09 UTC
New commit detected on ManageIQ/manageiq-ui-classic/ivanchuk:

https://github.com/ManageIQ/manageiq-ui-classic/commit/8d2b53aeb68b974f9cb42d3728193feff9b3f874
commit 8d2b53aeb68b974f9cb42d3728193feff9b3f874
Author:     Milan Zázrivec <mzazrivec@redhat.com>
AuthorDate: Fri Aug  2 04:53:18 2019 -0400
Commit:     Milan Zázrivec <mzazrivec@redhat.com>
CommitDate: Fri Aug  2 04:53:18 2019 -0400

    Merge pull request #5925 from h-kataria/fix_list_of_ansible_tower_templates

    Changed model name when showing list of Tower Templates.

    (cherry picked from commit e440234a4bd3f30ac160d7c2e02a5f1a90d6c50a)

    https://bugzilla.redhat.com/show_bug.cgi?id=1656734

 app/controllers/automation_manager_controller.rb | 4 +-
 product/views/ManageIQ_Providers_AnsibleTower_AutomationManager_ConfigurationScript.yaml | 82 +
 spec/controllers/automation_manager_controller_spec.rb | 2 +-
 3 files changed, 85 insertions(+), 3 deletions(-)

Comment 6 Satyajit Bulage 2019-08-20 13:29:06 UTC
Able to see only Ansible Tower Templates, not the Embedded Ansible entities.

Verified Version: 5.11.0.19.20190813184334_ed72c9f

Comment 8 errata-xmlrpc 2019-12-12 13:34:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4199


Note You need to log in before you can comment on or make changes to this bug.