Bug 1656812 - rebase sos to 3.7 in RHEL7.7
Summary: rebase sos to 3.7 in RHEL7.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks: 1637849
TreeView+ depends on / blocked
 
Reported: 2018-12-06 11:36 UTC by Pavel Moravec
Modified: 2019-08-06 13:15 UTC (History)
6 users (show)

Fixed In Version: sos-3.7-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:15:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2295 None None None 2019-08-06 13:15:53 UTC

Description Pavel Moravec 2018-12-06 11:36:41 UTC
I would like to rebase sos package in RHEL7.7 to upstream 3.7 version planned to be released in Q1 2019 / before 7.7 devel freeze. Reasons:

- several features and adjutments are planned for the release that can be nontrivial to backport one after another (while the features are worth to offer to customers and CEE). So it is much easier to pack a stable upstream version than try to apply patches to downstream.

- there will be smaller "testing distance" between upstream and RHEL

- rebasing will simplify future downstream work, esp. later on when working on z-stream patches


Version-Release number of selected component (if applicable):
sos-3.6-*


How reproducible:
100%


Steps to Reproduce:
1. rpm -q sos


Actual results:
sos-3.6-*


Expected results:
sos-3.7-*


Additional info:

Comment 2 Pavel Moravec 2019-03-27 20:43:16 UTC
technically, FailedQA since:

# rpm -q sos
sos-3.7-1.el7.noarch
# sosreport 

sosreport (version 3.6)

..


Trivial fix (just the 2nd part applies to downstream):

diff --git a/sos.spec b/sos.spec
index 95249670..68aedcfd 100644
--- a/sos.spec
+++ b/sos.spec
@@ -2,7 +2,7 @@
 
 Summary: A set of tools to gather troubleshooting information from a system
 Name: sos
-Version: 3.6
+Version: 3.7
 Release: 1%{?dist}
 Group: Applications/System
 Source0: http://people.redhat.com/breeves/sos/releases/sos-%{version}.tar.gz
diff --git a/sos/__init__.py b/sos/__init__.py
index c436bd20..dfc7ed5f 100644
--- a/sos/__init__.py
+++ b/sos/__init__.py
@@ -25,7 +25,7 @@ if six.PY3:
 else:
     from ConfigParser import ConfigParser, ParsingError, Error
 
-__version__ = "3.6"
+__version__ = "3.7"
 
 gettext_dir = "/usr/share/locale"
 gettext_app = "sos"


will fix in a day or two

Comment 6 errata-xmlrpc 2019-08-06 13:15:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2295


Note You need to log in before you can comment on or make changes to this bug.