Bug 1656835 - On RHV-4.2, Host installation fail in a cluster 4.1
Summary: On RHV-4.2, Host installation fail in a cluster 4.1
Keywords:
Status: CLOSED DUPLICATE of bug 1517538
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Martin Perina
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 12:33 UTC by Ilanit Stein
Modified: 2019-04-28 10:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 11:02:50 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
ovirt-host-deploy.log (5.24 KB, text/plain)
2018-12-06 12:35 UTC, Ilanit Stein
no flags Details

Description Ilanit Stein 2018-12-06 12:33:58 UTC
Description of problem:
On a RHV-4.2, Install host in a 4.1 cluster fail.
 
This is the event with the failure:
Host host_mixed_2 installation failed. Failed to execute Ansible host-deploy role. Please check logs for more details: /var/log/ovirt-engine/host-deploy/ovirt-host-deploy-ansible-20181206133201-automation-cfme-08.lab.eng.tlv2.redhat.com-27c51b02.log. (attached)

In this log,
the indicated problem is:  
"VDSM version 4.19.51 is not supported for FirewallD."

Version-Release number of selected component (if applicable):
RHV-4.2-8-1

Steps to Reproduce:
1. Have a RHV 4.2
2. Add a Data center & a cluster, from compatibility 4.1
3. Prepare a host, installed with RHEL=7.5 & have rhv-4.1.11 repos,
and install vdsm on it (vdsm-4.19.51-1.el7ev.x86_64)
4. Add this RHV-4.1 host to the 4.1 Cluster.
5. Host installation fail on the above error.
Same result happen also if the Automatic firewall checkbox is not checked (which is the default).

Expected results:
A RHV-4.1 host installation should succeed in RHV-4.2.

Comment 1 Ilanit Stein 2018-12-06 12:35:50 UTC
Created attachment 1512109 [details]
ovirt-host-deploy.log

Comment 2 Sandro Bonazzola 2018-12-10 10:54:07 UTC
Martin can you look into this?

Comment 3 Martin Perina 2018-12-11 11:02:50 UTC
The error is correct, firewalld support is not based on cluster level, but on VDSM version installed on the host. In RHVM 4.2 we are setting firewall type to firewalld by default for newly created datacenters with version greater than 4.0, because:

1. iptables has been deprecated on RHEL 7 and firewalld should be used instead
2. If you are using RHEL on the host, then this situation should not happen, because you should get VDSM from RHV 4.2 (all RHV 4.y hosts shares the same software channel) and that should support firewalld already
3. If you are using RHVH < 4.2 on the host, then you either need to use RHVH 4.2 (which can be added to clusters with version < 4.2 without any issues) or change firewall type of cluster back to iptables.

*** This bug has been marked as a duplicate of bug 1517538 ***


Note You need to log in before you can comment on or make changes to this bug.