Bug 1656838 - fix_auth says it is fixing database.yml.yaml
Summary: fix_auth says it is fixing database.yml.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.6
Hardware: x86_64
OS: Linux
low
low
Target Milestone: GA
: 5.11.0
Assignee: Keenan Brock
QA Contact: Jaroslav Henner
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 12:44 UTC by Jaroslav Henner
Modified: 2019-12-18 13:04 UTC (History)
4 users (show)

Fixed In Version: 5.11.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-12 13:34:53 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4199 None None None 2019-12-12 13:35:08 UTC

Description Jaroslav Henner 2018-12-06 12:44:19 UTC
Description of problem:
When executing the fix_auth.rb script, it says 
# /var/www/miq/vmdb/tools/fix_auth.rb --databaseyml --password PASS
fixing /var/www/miq/vmdb/config/database.yml.yaml

which is probably some mishap as there is
 /var/www/miq/vmdb/config/database.yml (note no .yaml suffix)


Version-Release number of selected component (if applicable):
cfme-5.9.6.5-3.el7cf.x86_64

How reproducible:
2/2

Steps to Reproduce:
1.
2.
3.

Actual results:
Incorrect message

Expected results:
Fixing ...database.yml

Additional info:

Comment 3 CFME Bot 2018-12-14 16:06:26 UTC
New commit detected on ManageIQ/manageiq/master:

https://github.com/ManageIQ/manageiq/commit/87c20a188a7b3184614054d689fd5ae9f9309db2
commit 87c20a188a7b3184614054d689fd5ae9f9309db2
Author:     Keenan Brock <keenan@thebrocks.net>
AuthorDate: Fri Dec  7 17:01:03 2018 -0500
Commit:     Keenan Brock <keenan@thebrocks.net>
CommitDate: Fri Dec  7 17:01:03 2018 -0500

    Change fix_auth database.yml status display

    fix_auth currently states it fixes [table].[column]
    In the case of database.yml, it fixes "database.yml" "yml" contents
    aka:
    fixing /var/www/miq/vmdb/config/database.yml.yaml

    This is a little confusing.

    The fix is to change the "table" name to "database"
    and the field name to "yml" so it displays the way the customers want

    https://bugzilla.redhat.com/show_bug.cgi?id=1656838

 tools/fix_auth/models.rb | 13 +-
 1 file changed, 8 insertions(+), 5 deletions(-)

Comment 4 Jaroslav Henner 2019-05-10 08:40:08 UTC
I reproduced this on 5.7 and then again restored the DB on 5.7 appliance and then migrated the data and then tried the fix_auth and succeed:

[root@localhost vmdb]# fix_auth --databaseyml -i config/database.yml
fixing /var/www/miq/vmdb/config/database.yml.yaml
processed 1 records
[root@localhost vmdb]# fix_auth -i invalid
fixing authentications.password, auth_key
processed 23 records
fixing miq_databases.registration_http_proxy_server, session_secret_token, csrf_secret_token
processed 1 records
fixing miq_ae_values.value
processed 147 records
fixing miq_ae_fields.default_value
processed 55 records
fixing settings_changes.value
processed 8 records
fixing miq_requests.options
processed 4 records
fixing miq_request_tasks.options
processed 4 records

Comment 6 errata-xmlrpc 2019-12-12 13:34:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4199


Note You need to log in before you can comment on or make changes to this bug.