Bug 1656872 - System admin is unable to see organizations that isn't assigned to him
Summary: System admin is unable to see organizations that isn't assigned to him
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Sanket Jagtap
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 14:58 UTC by Sanket Jagtap
Modified: 2018-12-12 08:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-12 08:41:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sanket Jagtap 2018-12-06 14:58:10 UTC
Description of problem:
System admin role user can only manage the org/loc that he is associated with.
He is not able to list other organizations, so system admin role user can now only manage the org/loc that he created.


Version-Release number of selected component (if applicable):
Satellite 6.5.0 snap6 

How reproducible:
Always


Steps to Reproduce:
1. Create a organization from admin user.
2. Create a user with System Admin, and login with that user


Actual results:
System admin is unable to view the org created by admin

Expected results:
System admin should be able to view, manage all org's but not have access to entities in Orgs expect user 

Additional info:

Comment 2 Marek Hulan 2018-12-07 13:25:48 UTC
This is intended, users should only work with organizations that are assigned to the them. System admin role main purpose is to configure Satellite, not touching organization specific data. Note that this user has permission to assign himself to additional organizations and locations if needed. He can edit his/her account, add himself/herself some org and then e.g. create Org admin for this org.

Sanket if you agree, I'd proceed with closing as not a bug.

Comment 3 Sanket Jagtap 2018-12-12 08:41:14 UTC
Closing this, as it is expected scenario.


Note You need to log in before you can comment on or make changes to this bug.