Bug 1656879 - update jenkins-sync-plugin to use org.jenkins-ci.plugins:cloudbees-folder:6.6
Summary: update jenkins-sync-plugin to use org.jenkins-ci.plugins:cloudbees-folder:6.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 15:30 UTC by Ian Tewksbury
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: cloudbees-folder plugin to 6.6 Highlights, important fixes, or notable enhancements: picks up fixes and enhancements for the jenkins plugin, which openshift sync plugin depends on, and allows for better integration with later versions of Jenkins 2.x
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:20 UTC

Description Ian Tewksbury 2018-12-06 15:30:11 UTC
Description of problem:
Currently jenkins-sync-plugin uses version 5.18 but that doesn't work when you install the jenkins-sync-plugin on a newer jenkins with a newer version of the cloubees-folder plugin, such as version 6.6.

What happens is that the synced jobs do not end up in the correct folder which then causes none of the build start and syncing to work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install jenkins-sync-plugin in CloudBees 2.x
2. attempt to do pipeline sync
3. pipelines will show up but wont be able to start becasue they wont be nested in the correct folder

Actual results:
pipelines will show up but wont be able to start becasue they wont be nested in the correct folder


Expected results:
pipelines should be put in the correct folder


Additional info:
https://github.com/openshift/jenkins-sync-plugin/pull/275

I couldn't find a component for the jenkins-sync-plugin so just took a stab about where to put this bugzilla.

Comment 2 Gabe Montero 2018-12-17 15:39:38 UTC
the jenkins image and sync plugin have been updated to allow this move to 6.6 cloudbees-folders

Ian reported that the initial pipeline bc job creation was now going into the folder, but subsequent
ones were not.

When I circle back to this, if I can reproduce that locally, I'll investigate what additional (probably 
sync plugin) changes are needed.  Otherwise, this possibly is an issue with his custom env.

Comment 3 Gabe Montero 2018-12-18 19:52:26 UTC
I've verified the version is updated.  Moving to verified directly.  I've exchanged some comments with Ian
in his PR.  We'll open a separate bugzilla for any other issues wrt folders if it relates to the sync plugin.

Comment 6 errata-xmlrpc 2019-06-04 10:41:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.