Bug 1656895 - Libvirt fails to start a VM using SPICE graphics with OpenGL turned off with error "No DRM render nodes available"
Summary: Libvirt fails to start a VM using SPICE graphics with OpenGL turned off with ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Erik Skultety
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 15:49 UTC by Erik Skultety
Modified: 2018-12-07 09:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 09:13:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1628892 None CLOSED Permission denied when start guest with egl-headless display 2019-09-18 07:06:09 UTC

Internal Links: 1628892

Description Erik Skultety 2018-12-06 15:49:00 UTC
Description of problem:
Libvirt is trying to pick a default DRI renderer for SPICE even if the XML doesn't have OpenGL turned on using <gl enable='yes'/>. This is a problem on a headless server without DRI because it fails to start a domain which previously started just fine.

Version-Release number of selected component (if applicable):
libvirt-5.0.0

How reproducible:
100% if the host doesn't have DRI

Steps to Reproduce:
1. prepare a VM with the following in the XML:
  <graphics type='spice'>
    <listen type='none'/>
  </graphics>
2. rename all /dev/dri/renderDX devices (skip if your host doesn't have DRI)
3. start the VM using virsh

Actual results:
error: Failed to start domain f-live
error: internal error: No DRM render nodes available

Expected results:
The domain starts just fine.

Additional info:

Comment 1 Erik Skultety 2018-12-06 16:13:55 UTC
Patch proposed upstream:
https://www.redhat.com/archives/libvir-list/2018-December/msg00176.html

Comment 2 Erik Skultety 2018-12-07 09:13:44 UTC
I'm closing this as NOTABUG since the intended future version of libvirt (5.0.0) will have this fixed, so technically there wouldn't be an issue to reproduce. However, I'm moving the reproducer for test verification purposes to the BZ linked below.


Note You need to log in before you can comment on or make changes to this bug.