Bug 1656923 - python-fuse ships python2-fuse, but that already is build by fuse-python
Summary: python-fuse ships python2-fuse, but that already is build by fuse-python
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-fuse
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Juan Orti Alcaine
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2REMOVAL
TreeView+ depends on / blocked
 
Reported: 2018-12-06 16:36 UTC by Miro Hrončok
Modified: 2018-12-12 19:32 UTC (History)
1 user (show)

Fixed In Version: python-fuse-2.0.4-10.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-12 19:32:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2018-12-06 16:36:31 UTC
From the python-fuse SRPM, 2 packages are created python2-fuse and python3-fuse.
However fuse-python also creates python2-fuse.

I guess there are a few things to consider here:

it appears that python2-fuse is required by:

bup-0:0.29.1-2.fc29.x86_64
ewftools-0:20140608-12.fc29.x86_64
fuse-s3fs-0:0.9-15.fc29.noarch
nfspy-0:1.0-14.fc29.noarch


Not sure what package they actually need, however what is packaged as python-fuse in Fedora is called fusepy upstream.

I suggest to rename the package to python-fusepy.

Also, please drop the Python 2 subpackage as part of https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

Thanks.


Note You need to log in before you can comment on or make changes to this bug.