Bug 1656939 - Incron causes defunct processes
Summary: Incron causes defunct processes
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: incron   
(Show other bugs)
Version: epel7
Hardware: x86_64 Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 17:13 UTC by Jay Leafey
Modified: 2019-02-12 02:55 UTC (History)
13 users (show)

Fixed In Version: incron-0.5.12-9.fc28 incron-0.5.12-9.fc29 incron-0.5.12-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-01-16 01:42:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Leafey 2018-12-06 17:13:15 UTC
Description of problem:

Since the update in EPEL to 0.5.12, every time incron handles a filesystem event it creates a "zombie" process.  This happens less frequently when the events are from the system incrontab files (/etc/incron.d/) but happens every single time when the event is from a user incrontab.

Version-Release number of selected component (if applicable):

CentOS 7 (1810) (7.6)
incron 0.5.12-16

How reproducible:

Easily reproducible.

Steps to Reproduce:
1. Install the incron RPM from EPEL
2. Set up a user incrontab monitoring a specific directory:
/home/jleafey/incrontest	IN_CLOSE_WRITE	"$% detected on file $@/$#" | logger --priority user.notice

3. Count defunct processes before test
4. Create files in the monitored directory
5. Count defunct processes after test

Actual results:

An additional defunct process is created for every file created in the monitored directory.

Expected results:

No defunct processes would be created when monitored filesystem events were processed.

Additional info:


I have rebuilt incrond directly from the sources on Github and it does not cause the same behaviour, events get processed and no zombies are left.  I compared the build logs from the RPM build to the "raw" build and the options provide to G++ are different.

From "rpmbuild -bc":
g++ -c  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic 

From "make":
g++ -c  -O2 -pedantic -std=c++11 -g0 -pipe -Wall -W -Wshadow -Wpointer-arith -Wwrite-strings -ffor-scope

Comment 1 Jay Leafey 2018-12-06 17:55:52 UTC
I was curious to see if this also occurred with the Fedora package, so I build a Fedora 29 server VM for testing.  I used exactly the same test case and got exactly the same results, using the packaged incron from Fedora's repositories causes a zombie process to be left after processing each filesystem event.  I have not tried building from source on the test system yet.

Comment 2 Robert Scheck 2018-12-28 11:03:46 UTC
From my point of view, this is a 0.5.12 issue (I'm also seeing massive memory leaks with 0.5.12 that did not exist with an identical configuration at 0.5.10).

Comment 3 Passur IT 2019-01-03 16:51:45 UTC
We are having this problem too on production systems.  After enough time and incron actions, it actually causes system issues.  Please back out this version for the time-being as it is clearly unstable.  I think that's the prudent thing to do until the package can be tested more.  Delays are only going to lead to more people having issues.

Comment 4 Kevin Fenzi 2019-01-05 19:57:15 UTC
Can you all please try this scratch build and see if the problem is fixed: 

https://koji.fedoraproject.org/koji/taskinfo?taskID=31840653

If that looks good, I will push an update (for epel7 and f29/f28 as the fix applies to them all)

Comment 5 Maxime HAMON 2019-01-07 14:18:23 UTC
Everything looks good for me. No more defunct process

Comment 6 Remco 2019-01-07 19:39:21 UTC
Works good for me on CentOS7 as well!

Comment 7 nick 2019-01-07 19:40:02 UTC
had the same issue, thanks for fixing this :)

Comment 8 Fedora Update System 2019-01-07 22:36:49 UTC
incron-0.5.12-9.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bbc0a2c14a

Comment 9 Fedora Update System 2019-01-07 22:37:03 UTC
incron-0.5.12-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-60b62db475

Comment 10 Fedora Update System 2019-01-07 22:37:33 UTC
incron-0.5.12-9.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-75bfa8d4a2

Comment 11 Fedora Update System 2019-01-08 00:56:18 UTC
incron-0.5.12-9.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-75bfa8d4a2

Comment 12 Fedora Update System 2019-01-08 01:11:27 UTC
incron-0.5.12-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-60b62db475

Comment 13 Fedora Update System 2019-01-08 02:05:13 UTC
incron-0.5.12-9.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bbc0a2c14a

Comment 14 Jay Leafey 2019-01-08 17:47:11 UTC
I have installed incron-0.5.12-9.el7 from testing on one of the systems where the problem originally occurred.  After a couple of hours of testing I have seen no defunct processes.  I have tested both user and system incrontabs and so far have not seen any issues.

Comment 15 Matthew Miller 2019-01-11 15:41:39 UTC
Yes, I'm hitting this too -- I've installed the update and will test.

Comment 16 Fedora Update System 2019-01-16 01:42:34 UTC
incron-0.5.12-9.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-01-16 02:19:34 UTC
incron-0.5.12-9.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-02-12 02:55:50 UTC
incron-0.5.12-9.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.