Bug 165699 - NM can not connect if dhcp does not offer a default route
NM can not connect if dhcp does not offer a default route
Status: CLOSED DUPLICATE of bug 165698
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 08:57 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-11 09:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2005-08-11 08:57:29 EDT
Description of problem:
NM seems to expect the dhcp server to deliver a default route when connecting to
a wireless access point. If no default route is offered, the following appears
in the syslog and connecting fails:

dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1
for sub-path eth1.dbus.get.routers
NetworkManager: <WARNING>    (): get_ip4_uint32(): error calling 'routers', DHCP
daemon returned error 'org.freedesktop.DBus.Error.UnknownMethod', message
'Method "routers" with signature "" on interface "com.redhat.dhcp.dbus.get"
doesn't exist '.

The connection is then torn down.
The dhcp server offers an IP address, a netmask, a broadcast address and a DNS
server, which is enough for the case in question.

Version-Release number of selected component (if applicable):
NetworkManager-0.4-34.cvs20050729


How reproducible:
Always

Steps to Reproduce:
1. Set up dhcp server without "option routers"
2. try to connect with NM
3.
  
Actual results:
Connect fails

Expected results:
connect succeeds

Additional info:
Comment 1 Dan Williams 2005-08-11 09:15:25 EDT

*** This bug has been marked as a duplicate of 165698 ***

Note You need to log in before you can comment on or make changes to this bug.