Bug 1656991 - update Singularity packages in EPEL to 3.x
Summary: update Singularity packages in EPEL to 3.x
Keywords:
Status: CLOSED DUPLICATE of bug 1693909
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: singularity
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Dykstra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 19:42 UTC by Paul Stauffer
Modified: 2019-04-12 19:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-12 19:59:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Stauffer 2018-12-06 19:42:56 UTC
The packages for Singularity in EPEL7 are still at 2.6.0.  There has been a major rewrite for 3.x, and it would be great to get the current release available in EPEL, either as an update to the existing package, or as a parallel "singularity3" package.

Comment 1 Dave Dykstra 2018-12-06 21:35:33 UTC
I have started to work on it. The version of golang in rhel7 was too old until today when the latest version was released in epel7 (because RHEL 7.6 removed golang except in devtoolset).  Beyond that, since singularity-3 is such a major update, it's going to require a lot of testing before I'll be willing to let it replace singularity-2.6.0 as the default.  I think there are some things that will break current users and I want to avoid that as much as possible.  I expect it will take at least one more release of singularity 3.x.  Meanwhile I think I'll put it in the testing repositories.

I'd rather avoid a singularity3 package.  singularity-3 does attempt to be mostly compatible with singularity-2, it's just going to take a little more work before it is close enough.

Dave

Comment 2 Dave Dykstra 2019-02-26 22:41:56 UTC
singularity-3.0.3 is now the default for f28 and f29.  However I still want to see more improvements and testing before putting singularity-3 in EPEL, to make sure that it doesn't break use cases of people using it in production.  I know of one issue that does break a production use case, in https://github.com/sylabs/singularity/issues/2588, so I need to wait at least until that is fixed.  Meanwhile I don't want to put it into epel-testing either, in case there's another security release like 2.6.1; I wouldn't want a singularity-3 version in testing to get in the way of a 2.6.2.

Comment 3 Dave Dykstra 2019-04-12 19:57:56 UTC
This is to be done in bug #1693909.  singularity-3.1.1 is now in epel-testing.  Please give karma.

Comment 4 Dave Dykstra 2019-04-12 19:59:29 UTC

*** This bug has been marked as a duplicate of bug 1693909 ***


Note You need to log in before you can comment on or make changes to this bug.