Bug 1657051 - TypeError: Argument 0 does not allow None as a value
Summary: TypeError: Argument 0 does not allow None as a value
Keywords:
Status: CLOSED DUPLICATE of bug 1628519
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:fb4c9daba099f2484cbcbd26cd9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 23:08 UTC by Jan Gerrit Kootstra
Modified: 2018-12-07 09:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 09:49:16 UTC
Type: ---
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (1.87 MB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: anaconda.log (134.86 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: dbus.log (3.61 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: dnf.librepo.log (18.04 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: environ (637 bytes, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: hawkey.log (160.26 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: lorax-packages.log (24.11 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: lsblk_output (1.25 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: nmcli_dev_list (1.66 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: os_info (513 bytes, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: program.log (34.09 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: storage.log (649.89 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: syslog (244.48 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: ifcfg.log (3.26 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details
File: packaging.log (41.17 KB, text/plain)
2018-12-06 23:08 UTC, Jan Gerrit Kootstra
no flags Details

Description Jan Gerrit Kootstra 2018-12-06 23:08:07 UTC
Version-Release number of selected component:
anaconda-29.19.0.25

The following was filed automatically by anaconda:
anaconda 29.19.0.25 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/gi/overrides/GLib.py", line 118, in _create
    return self._LEAF_CONSTRUCTORS[format](value)
  File "/usr/lib64/python3.6/site-packages/gi/overrides/GLib.py", line 150, in _create
    builder.add_value(self._create(dup, i))
  File "/usr/lib64/python3.6/site-packages/gi/overrides/GLib.py", line 172, in __new__
    v = creator._create(format_string, value)
  File "/usr/lib/python3.6/site-packages/pydbus/proxy_method.py", line 80, in __call__
    GLib.Variant(self._sinargs, args),
  File "/usr/lib64/python3.6/site-packages/pyanaconda/storage/osinstall.py", line 1564, in update_ksdata
    auto_part_proxy.SetLUKSVersion(self.autopart_luks_version)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 383, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 286, in run
    threading.Thread.run(self)
TypeError: Argument 0 does not allow None as a value

Additional info:
addons:         com_redhat_kdump, org_fedora_oscap
cmdline:        /usr/libexec/platform-python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=RHEL-8-0-BaseOS-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.18.0-32.el8.x86_64
product:        Red Hat Enterprise Linux 8
release:        Red Hat Enterprise Linux release 8.0 Beta (Ootpa)
release_type:   pre-release
type:           anaconda
version:        8.0

Comment 1 Jan Gerrit Kootstra 2018-12-06 23:08:14 UTC
Created attachment 1512314 [details]
File: anaconda-tb

Comment 2 Jan Gerrit Kootstra 2018-12-06 23:08:16 UTC
Created attachment 1512315 [details]
File: anaconda.log

Comment 3 Jan Gerrit Kootstra 2018-12-06 23:08:17 UTC
Created attachment 1512316 [details]
File: dbus.log

Comment 4 Jan Gerrit Kootstra 2018-12-06 23:08:18 UTC
Created attachment 1512317 [details]
File: dnf.librepo.log

Comment 5 Jan Gerrit Kootstra 2018-12-06 23:08:19 UTC
Created attachment 1512318 [details]
File: environ

Comment 6 Jan Gerrit Kootstra 2018-12-06 23:08:21 UTC
Created attachment 1512319 [details]
File: hawkey.log

Comment 7 Jan Gerrit Kootstra 2018-12-06 23:08:23 UTC
Created attachment 1512320 [details]
File: lorax-packages.log

Comment 8 Jan Gerrit Kootstra 2018-12-06 23:08:24 UTC
Created attachment 1512321 [details]
File: lsblk_output

Comment 9 Jan Gerrit Kootstra 2018-12-06 23:08:25 UTC
Created attachment 1512322 [details]
File: nmcli_dev_list

Comment 10 Jan Gerrit Kootstra 2018-12-06 23:08:26 UTC
Created attachment 1512323 [details]
File: os_info

Comment 11 Jan Gerrit Kootstra 2018-12-06 23:08:28 UTC
Created attachment 1512324 [details]
File: program.log

Comment 12 Jan Gerrit Kootstra 2018-12-06 23:08:30 UTC
Created attachment 1512325 [details]
File: storage.log

Comment 13 Jan Gerrit Kootstra 2018-12-06 23:08:32 UTC
Created attachment 1512326 [details]
File: syslog

Comment 14 Jan Gerrit Kootstra 2018-12-06 23:08:33 UTC
Created attachment 1512327 [details]
File: ifcfg.log

Comment 15 Jan Gerrit Kootstra 2018-12-06 23:08:35 UTC
Created attachment 1512328 [details]
File: packaging.log

Comment 16 Jiri Konecny 2018-12-07 09:49:16 UTC
Thank you for your report. We are already working on this issue.

*** This bug has been marked as a duplicate of bug 1628519 ***


Note You need to log in before you can comment on or make changes to this bug.