Bug 1657060 - Mirrors not updating with kernel 4.19.6
Summary: Mirrors not updating with kernel 4.19.6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Justin M. Forbes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 00:20 UTC by Josh Berkus
Modified: 2018-12-07 17:09 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 16:14:00 UTC


Attachments (Terms of Use)

Description Josh Berkus 2018-12-07 00:20:08 UTC
Description of problem:

No RPMs are available for kernel-devel and kernel-modules for kernel-4.19.5-300.  All attempts to get these rpms will 404.

Version-Release number of selected component (if applicable):

4.19.5-300.fc29.x86_64.rpm

How reproducible:

100%

Steps to Reproduce:
1. Install a new Fedora-Cloud-Base-29 system on AWS
2. Attempt to install the kernel-devel package
3. Get 404 timeout failure

Actual results:

[MIRROR] kernel-devel-4.19.5-300.fc29.x86_64.rpm: Status code: 404 for http://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/updates/29/Everything/x86_64/Packages/k/kernel-devel-4.19.5-300.fc29
.x86_64.rpm                                                                                                                                                                                       
[MIRROR] kernel-devel-4.19.5-300.fc29.x86_64.rpm: Status code: 404 for http://mirror.math.princeton.edu/pub/fedora/linux/updates/29/Everything/x86_64/Packages/k/kernel-devel-4.19.5-300.fc29.x86_6
4.rpm                                                                                                                                                                                             
[MIRROR] kernel-devel-4.19.5-300.fc29.x86_64.rpm: Status code: 404 for http://kdeforge2.unl.edu/mirrors/fedora/linux/updates/29/Everything/x86_64/Packages/k/kernel-devel-4.19.5-300.fc29.x86_64.rp
m          

Expected results:

kernel-devel should install.

Additional info:

This affect the Glusterfs kernel modules as well.  Not sure what other modules are affected.

I'm aware that an update to 4.19.6 was released last night, but (for some reason) that's not available for Cloud Base yet.

Comment 1 Josh Berkus 2018-12-07 00:55:55 UTC
Further information:

The actual problem is different: it's that 4.19.6 is not available from a large part of the mirror network.

After trying a number of things, the only way to upgrade to 4.19.6 was to hand-pick an updated mirror and paste it directly into fedora-updates.repo.

Otherwise, I got this:

[root@ip-172-31-14-197 ~]# dnf clean all
29 files removed
[root@ip-172-31-14-197 ~]# dnf update --refresh
Fedora Modular 29 - x86_64                                                                                                                                         440 kB/s | 1.5 MB     00:03    
Fedora Modular 29 - x86_64 - Updates                                                                                                                               521 kB/s | 1.7 MB     00:03    
Fedora 29 - x86_64 - Updates                                                                                                                                        10 MB/s |  16 MB     00:01    
Fedora 29 - x86_64                                                                                                                                                  24 MB/s |  62 MB     00:02    
Dependencies resolved.
Nothing to do.
Complete!
[root@ip-172-31-14-197 ~]# dnf install kernel
Last metadata expiration check: 0:00:33 ago on Fri 07 Dec 2018 12:54:29 AM UTC.
Dependencies resolved.
===================================================================================================================================================================================================
 Package                                           Arch                                      Version                                              Repository                                  Size
===================================================================================================================================================================================================
Installing:
 kernel                                            x86_64                                    4.19.5-300.fc29                                      updates                                     26 k
Installing dependencies:
 kernel-modules                                    x86_64                                    4.19.5-300.fc29                                      updates                                     28 M

Transaction Summary
===================================================================================================================================================================================================
Install  2 Packages

Total download size: 28 M
Installed size: 27 M


Updating title of bug accordingly.

Comment 2 Josh Berkus 2018-12-07 01:02:44 UTC
To sum up: the problem is that while kernel-4.19.6 is not available on many mirrors, those mirrors have already deleted the 4.19.5 modules and kernel headers.

Comment 3 Laura Abbott 2018-12-07 16:14:00 UTC
This is not an issue with the kernel. This is a Fedora infrastructure issue. In the future please file a ticket at https://pagure.io/fedora-infrastructure/issues  for anything related to syncing of RPMs.

Comment 4 Josh Berkus 2018-12-07 17:09:05 UTC
Thanks, filing bug in Pagure.


Note You need to log in before you can comment on or make changes to this bug.