Bug 1657076 - subscription manager register activation key with special character failed
Summary: subscription manager register activation key with special character failed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On: 1665277 1803919
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 03:03 UTC by yanpliu
Modified: 2020-02-17 17:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1665277 (view as bug list)
Environment:
Last Closed: 2020-02-03 16:30:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
activationkey.png (108.92 KB, image/png)
2018-12-07 03:24 UTC, yanpliu
no flags Details
cockpit_activationkey.png (118.63 KB, image/png)
2018-12-07 03:24 UTC, yanpliu
no flags Details
Create_activationkey_using_specail_characters.log (3.72 KB, text/plain)
2019-01-10 02:35 UTC, yanpliu
no flags Details
register_satellite_server_with_specailcharacters_by_subscriptionmanager.log (847 bytes, text/plain)
2019-01-10 02:36 UTC, yanpliu
no flags Details
register_satelliteserver_using_specailcharacters_by_cockpit.log (847 bytes, text/plain)
2019-01-10 02:36 UTC, yanpliu
no flags Details
create_activationkey_by!@#$%^&*()_+-={}{}[<.>.log (3.27 KB, text/plain)
2019-01-10 02:36 UTC, yanpliu
no flags Details
register_satelliteserver_!@#$%^&*()_+-={}{}[<.>_by_subscriptionmanager.log (16.47 KB, text/plain)
2019-01-10 02:37 UTC, yanpliu
no flags Details

Description yanpliu 2018-12-07 03:03:14 UTC
Description of problem:
subscription manager register activationkey with special character failed

Version-Release number of selected component (if applicable):
subscription-manager-1.23.8-4.el8.x86_64
subscription-manager-rhsm-certificates-1.23.8-4.el8.x86_64
python3-subscription-manager-rhsm-1.23.8-4.el8.x86_64
subscription-manager-cockpit-1.23.8-4.el8.noarch
dnf-plugin-subscription-manager-1.23.8-4.el8.x86_64

satellite6.4
katello-server-ca-1.0-1.noarch
katello-3.7.0-8.el7sat.noarch
candlepin-2.4.8-1.el7.noarch


How reproducible:
always

Steps to Reproduce:
1.Create a activationkey named ",.;?" on satellite6.4
Please reference picture
activationkey.png

2.Register satellite server with this activationkey
# subscription-manager register --org=Default_Organization --activationkey=',.;?'
HTTP error (404 - Not Found): Couldn't find activation key ''

3. Register satellite server with cockpit
Error:
HTTP error (404 - Not Found): Couldn't find activation key ''
Please reference picture
cockpit_activationkey.png

4. Used other special characters, it work well.
# subscription-manager register --org=Default_Organization --activationkey='!@#$%^&*()_+-={}{}[<.>'
The system has been registered with ID: 5978380b-9ba8-40aa-9d66-4f2641cfa403
The registered system name is: dell-r730-001-guest14.dsal.lab.eng.rdu2.redhat.com
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux for x86_64 High Touch Beta
Status:       Subscribed


Actual results:
As step 3

Expected results:
As satellite server support special character creation, register to satellite server also should support, even though we do not use this characters usually.
If we think these characters are not useful, maybe satellite server need to add validation for creating activate key using these special characters.


Additional info:

Comment 1 yanpliu 2018-12-07 03:24:28 UTC
Created attachment 1512349 [details]
activationkey.png

Comment 2 yanpliu 2018-12-07 03:24:47 UTC
Created attachment 1512350 [details]
cockpit_activationkey.png

Comment 4 yanpliu 2018-12-10 09:04:07 UTC
Hello Jenny,
I have tried in Stage and Satellite 6.5.

Stage:
Stage can not support creating activate key using special characters.
It would display warning message "Name may only contain letters, numbers, underscore, or hyphen ".

Satellite6.5:
Satellite6.5 has the same issue with satellite6.4.

So I think it maybe a Satellite candlepin issue.

Comment 7 Kevin Howell 2019-01-03 15:06:19 UTC
Can you provide candlepin logs?

Comment 8 yanpliu 2019-01-09 07:59:08 UTC
Hello Kevin,
Which candlepin log do you need? rhel register stage candlepin log or rhel regiter satellite candlepin log?
And how to catch these logs? Thanks.

Comment 9 Kevin Howell 2019-01-09 20:31:27 UTC
> Which candlepin log do you need? rhel register stage candlepin log or rhel regiter satellite candlepin log?

We would want to see the satellite candlepin log.

> And how to catch these logs?

On a Satellite server, you can grab the log from /var/log/candlepin/candlepin.log.

Comment 10 yanpliu 2019-01-10 02:34:10 UTC
Attached logs:

1.Create activation key using ",.;?" on satellite6.4 log:
Create_activationkey_using_specail_characters.log

2.Register satellite server with this activationkey by subscription manager
# subscription-manager register --org=Default_Organization --activationkey=',.;?'

register_satellite_server_with_specailcharacters_by_subscriptionmanager.log

3. Register satellite server with cockpit using activationkey=',.;?'
register_satelliteserver_using_specailcharacters_by_cockpit.log

5.Create activation key using "!@#$%^&*()_+-={}{}[<.>" on satellite6.4 log:
create_activationkey_by!@#$%^&*()_+-={}{}[<.>.log

6. Register satellite server with activationkey='!@#$%^&*()_+-={}{}[<.>' by subscription manager
# subscription-manager register --org=Default_Organization --activationkey='!@#$%^&*()_+-={}{}[<.>'
register_satelliteserver_!@#$%^&*()_+-={}{}[<.>_by_subscriptionmanager.log

Comment 11 yanpliu 2019-01-10 02:35:29 UTC
Created attachment 1519621 [details]
Create_activationkey_using_specail_characters.log

Comment 12 yanpliu 2019-01-10 02:36:00 UTC
Created attachment 1519622 [details]
register_satellite_server_with_specailcharacters_by_subscriptionmanager.log

Comment 13 yanpliu 2019-01-10 02:36:23 UTC
Created attachment 1519623 [details]
register_satelliteserver_using_specailcharacters_by_cockpit.log

Comment 14 yanpliu 2019-01-10 02:36:50 UTC
Created attachment 1519624 [details]
create_activationkey_by!@#$%^&*()_+-={}{}[<.>.log

Comment 15 yanpliu 2019-01-10 02:37:14 UTC
Created attachment 1519625 [details]
register_satelliteserver_!@#$%^&*()_+-={}{}[<.>_by_subscriptionmanager.log

Comment 16 Bryan Kearney 2020-01-15 21:01:15 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 17 Bryan Kearney 2020-02-03 16:30:37 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.