Bug 1657128 - [marketplace] Marketplace operator CSVs can’t be deployed because the wrong "serviceAccountName"
Summary: [marketplace] Marketplace operator CSVs can’t be deployed because the wrong ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Alexander Greene
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 07:35 UTC by Fan Jia
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:20 UTC

Description Fan Jia 2018-12-07 07:35:00 UTC
Description of problem:
marketplace CSVs file can’t be deployed ,  csv file phase failed with Message “one or more requirements couldn't be found”.  


Version-Release number of selected component (if applicable):
oc v4.0.0-alpha.0+99b66db-755
kubernetes v1.11.0+99b66db
OLM version: 0.8.0  git commit: 7afcd1e
marketplace : 0.1.0
marketplace operator CSV :https://github.com/operator-framework/operator-marketplace/blob/master/deploy/marketplace.csv.yaml


How reproducible:
Always


Steps to Reproduce:
1. created all the need crds & roles to the project marketplace
2. apply the csv file 
#oc apply -f marketplace.csv.yaml


Actual results:
1) #oc get csv -n marketplace 
NAME                          DISPLAY       VERSION   REPLACES   PHASE
marketplace-operator.v0.0.1   marketplace   0.0.1                Pending
2) #oc describe csv marketplace-operator.v0.0.1 -n marketplace
Status:
    Last Transition Time:  2018-12-06T06:28:31Z
    Last Update Time:      2018-12-06T06:28:31Z
    Message:               one or more requirements couldn't be found
    Phase:                 Pending
    Reason:                RequirementsNotMet
requirementStatus:
  - dependents:
    - group: rbac.authorization.k8s.io
      kind: PolicyRule
      message: cluster rule:{"verbs":["*"],"apiGroups":["marketplace.redhat.com"],"resources":["*"]}
      status: NotSatisfied
      version: v1beta1


Expected results:
#oc get csv -n marketplace
NAME                          DISPLAY       VERSION   REPLACES   PHASE
marketplace-operator.v0.0.1   marketplace   0.0.1                Succeeded


Additional info:
2) #oc describe csv marketplace-operator.v0.0.1 -n marketplace

Status:
      Conditions:
    Last Transition Time:  2018-12-06T02:51:21Z
    Last Update Time:      2018-12-06T02:51:21Z
    Message:               requirements not yet checked
    Phase:                 Pending
    Reason:                RequirementsUnknown
    Last Transition Time:  2018-12-06T02:51:21Z
    Last Update Time:      2018-12-06T02:51:21Z
    Message:               all requirements found, attempting install
    Phase:                 InstallReady
    Reason:                AllRequirementsMet
Dependents:
      Group:    rbac.authorization.k8s.io
      Kind:     PolicyRule
      Message:  cluster rule:{"verbs":["*"],"apiGroups":["marketplace.redhat.com"],"resources":["*"]}
      Status:   Satisfied
      Version:  v1beta1


Additional info:
The serviceAcccountName in the csv file is “default”, but the service_account file define the  service account is “marketplace-operator”.
So should modify the serviceAccountName from “default” to “marketplace-operator” in the csv file “marketplace.csv.yaml”

Comment 1 Alexander Greene 2018-12-07 21:48:59 UTC
This bug came as a result of the changes that were introduced when the project was rebuilt using version 0.1.1 of the operator sdk. In this update, the service account changed from default to marketplace-operator. I will update the csv to use this service account.

Comment 2 Alexander Greene 2018-12-07 22:13:24 UTC
The fix for this bug can be found in Pull Request 49 [1].

@Jian, could you please let me know what the next steps are? This is my first time addressing a bug at Red Hat. Thanks!

[1] PR Link: https://github.com/operator-framework/operator-marketplace/pull/49

Comment 3 Fan Jia 2018-12-11 07:46:12 UTC
@Greene,
You can modify the bug's status to "ON_QA" , then I will check it . Thanks

Comment 4 Alexander Greene 2018-12-11 13:05:20 UTC
@Jian: Thanks!

Comment 5 Fan Jia 2018-12-13 03:56:12 UTC
The new csv file is ok.

Comment 6 Alexander Greene 2018-12-26 14:13:41 UTC
Great! Are there any other steps that I need to take to close the bug?

Comment 7 Fan Jia 2018-12-27 02:19:40 UTC
It's ok just change the status from "verified" to "closed"

Comment 8 Alexander Greene 2019-01-02 13:55:59 UTC
I set it to "CLOSED" but it also asked for a resolution, I assumed that "CURRENTRELEASE" was the correct resolution. Please let me know if you require any changes.

Comment 9 Alexander Greene 2019-01-02 13:59:01 UTC
Based on this document it seems to have been the right move: https://mojo.redhat.com/docs/DOC-1092888

Comment 10 Fan Jia 2019-01-03 08:18:41 UTC
Greene, Sorry to tell you the wrong operating , the bug will close by script automaticlly.
I modified the status to "on_qa" --> "verified".
You don't need to do anything more.

Comment 13 errata-xmlrpc 2019-06-04 10:41:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.