Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1657130 - Can't migrate from rhel8 to rhel7 when guest xml has device "sound"
Summary: Can't migrate from rhel8 to rhel7 when guest xml has device "sound"
Keywords:
Status: CLOSED DUPLICATE of bug 1655820
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: qemu-kvm
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Dr. David Alan Gilbert
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 07:51 UTC by gaojianan
Modified: 2019-11-14 23:41 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 04:06:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
target and source migrate log (27.07 KB, text/plain)
2018-12-07 07:51 UTC, gaojianan
no flags Details

Description gaojianan 2018-12-07 07:51:56 UTC
Created attachment 1512407 [details]
target and source migrate log

Description of problem:
As subject

Version-Release number of selected component (if applicable):
libvirt-4.9.0-1.module+el8+2241+fdba4e12.x86_64
qemu-kvm-3.1.0-0.module+el8+2266+616cf026.next.candidate.x86_64

qemu-kvm-rhev-2.12.0-19.el7_6.2.x86_64
libvirt-4.5.0-10.el7_6.2.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a guest xml with device "video" in rhel8.
[root@localhost ~]# virsh list
 Id   Name    State   
-----------------------
 38   demo1   running 

[root@localhost ~]# virsh dumpxml demo1
...
    <sound model='ich9'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x1b' function='0x0'/>
    </sound>
...

2.Do migrate from rhel8 to rhel7.
[root@localhost ~]# virsh migrate demo4 --live --verbose qemu+ssh://10.66.4.170/system  --copy-storage-all
root@10.66.4.170's password:
Migration: [100 %]error: internal error: qemu unexpectedly closed the monitor: 2018-12-04T06:45:11.296515Z qemu-kvm: Failed to load hda-audio:st
2018-12-04T06:45:11.296751Z qemu-kvm: error while loading state for instance 0x0 of device 'hda-audio'
2018-12-04T06:45:11.296809Z qemu-kvm: warning: TSC frequency mismatch between VM (3092982 kHz) and host (2659999 kHz), and TSC scaling unavailable
2018-12-04T06:45:11.297457Z qemu-kvm: warning: TSC frequency mismatch between VM (3092982 kHz) and host (2659999 kHz), and TSC scaling unavailable
2018-12-04T06:45:11.297627Z qemu-kvm: load of migration failed: No such file or directory

Actual results:
As above

Expected results:
Can migrate successfully without error.

Additional info:

Comment 2 gaojianan 2018-12-10 04:06:06 UTC

*** This bug has been marked as a duplicate of bug 1655820 ***


Note You need to log in before you can comment on or make changes to this bug.