Bug 1657182 - ipa client uninstallation fails
Summary: ipa client uninstallation fails
Keywords:
Status: CLOSED DUPLICATE of bug 1654291
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa
Version: 8.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 11:22 UTC by Sergey Orlov
Modified: 2018-12-07 17:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 17:43:03 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Sergey Orlov 2018-12-07 11:22:49 UTC
Description of problem:
ipa-client-install --uninstall fails in authconfig invocation

Version-Release number of selected component (if applicable):

RHEL-8 image: RHEL-8.0-20181120.n.0-x86_64
ipa-client-4.7.1-5.module+el8+2239+1c5bd4cb.x86_64
authselect-compat-1.0-8.el8.x86_64


How reproducible:
Always


Steps to Reproduce:

1. have ipa server installed
2. ipa-client-install ...
3. ipa-client-install --uninstall -U

Actual results:
exit code 1
Last lines of ipa-client-install output:
```
WARNING: Unable to revert to the pre-installation state ('authconfig' tool has been deprecated in favor of 'authselect'). The default sssd profile will be used instead.
The authconfig arguments would have been: authconfig --disableldap --disablekrb5 --disablesssdauth --disablemkhomedir
Failed to remove krb5/LDAP configuration: CalledProcessError(Command ['/usr/bin/authselect', 'select', 'sssd', '', '--force'] returned non-zero exit status 1: '[error] Unknown profile feature []\n[error] Unable to activate profile [sssd] [22]: Invalid argument\nUnable to activate profile [22]: Invalid argument\n')
```

Expected results:
exit code 0, message "Client uninstall complete."

Additional info:
Uninstallation works with RHEL-8 build of 2018-11-20, it has previous version of authselect-compat and same version of ipa-client

authselect-compat-1.0-6.el8.x86_64
ipa-client-4.7.1-5.module+el8+2239+1c5bd4cb.x86_64
Last lines of output:

```
WARNING: Unable to revert to the pre-installation state ('authconfig' tool has been deprecated in favor of 'authselect'). The default sssd profile will be used instead.
The authconfig arguments would have been: authconfig --disableldap --disablekrb5 --disablesssdauth --disablemkhomedir
An error occurred while removing SSSD's cache.Please remove the cache manually by executing sssctl cache-remove -o.
Redundant SSSD configuration file /etc/sssd/sssd.conf was moved to /etc/sssd/sssd.conf.deleted
nscd daemon is not installed, skip configuration
nslcd daemon is not installed, skip configuration
Client uninstall complete.
```

Comment 1 Florence Blanc-Renaud 2018-12-07 17:43:03 UTC
This is a duplicate of BZ 1654291.

*** This bug has been marked as a duplicate of bug 1654291 ***


Note You need to log in before you can comment on or make changes to this bug.