Bug 165720 - VNC uses non-standard long options
VNC uses non-standard long options
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2005-08-11 11:14 EDT by Jonathan S. Shapiro
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-11 11:29:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2005-08-11 11:14:33 EDT
The silly buggers at realvnc.com don't seem to understand how command lines
work. As a transitional solution, I propose that vnc should accept either the
--longoption or -longoption forms interchangeably.

An easy way to do this is to check at the top of the string search against long
options, see if the arg pointer points to a string starting with "--", if so
advance it by one character, and then fall into the current checking code.

Obviously, this is not urgent. It just bugs me.
Comment 1 Tim Waugh 2005-08-11 11:29:03 EDT
You need to report this upstream, but I doubt this will change.  VNC is not a
GNU application.
Comment 2 Jonathan S. Shapiro 2005-08-11 12:23:35 EDT
You are probably right, but do you happen to know where/how to report it upstream?

Note You need to log in before you can comment on or make changes to this bug.