Bug 1657281 - USER_AVC denial between dbus-daemon and rhsmcertd_t
Summary: USER_AVC denial between dbus-daemon and rhsmcertd_t
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: selinux-policy
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On: 1673107
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 15:07 UTC by John Sefler
Modified: 2020-11-14 10:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:09:45 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3547 0 None None None 2019-11-05 22:09:56 UTC

Description John Sefler 2018-12-07 15:07:25 UTC
Description of problem:

The following was logged to /var/log/audit/audit.log during an automated test run.  Unfortunately I do not know the exact reproducer steps.  Please advise.

type=USER_AVC msg=audit(1544160457.712:22978): pid=737 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc: denied { send_msg } for msgtype=method_return dest=:1.2738 spid=21488 tpid=21485 scontext=system_u:system_r:rhsmcertd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:rpm_t:s0 tclass=dbus permissive=0 exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'UID="dbus" AUID="unset" SAUID="dbus"


Version-Release number of selected component (if applicable):
# rpm -q subscription-manager selinux-policy
subscription-manager-1.23.8-4.el8.aarch64
selinux-policy-3.14.1-48.el8.noarch


How reproducible:
unknown

Steps to Reproduce:
unknown

Actual results:


Expected results:


Additional info:

Comment 2 Kevin Howell 2019-01-07 15:41:45 UTC
No reliable reproducer (yet?).

Comment 11 errata-xmlrpc 2019-11-05 22:09:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3547


Note You need to log in before you can comment on or make changes to this bug.