Bug 1657364 - grub2-mkconfig fails with default options on /etc/default/grub
Summary: grub2-mkconfig fails with default options on /etc/default/grub
Keywords:
Status: CLOSED DUPLICATE of bug 1646976
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bootloader engineering team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 19:16 UTC by Nicolas Hicher
Modified: 2019-03-25 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 21:23:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nicolas Hicher 2018-12-07 19:16:38 UTC
Description of problem:

It not possible to generate a new grub config file with the default option set on /etc/default/grub

Version-Release number of selected component (if applicable):
rhel 7.6

How reproducible:

Always

Steps to Reproduce:

1 run  grub2-mkconfig -o grub.cfg


Actual results:

[root@rhel7 ~]# grub2-mkconfig -o grub.cfg
/etc/default/grub: line 6: no_timer_check: command not found

Expected results:

[root@rhel7 ~]# grub2-mkconfig -o grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.10.0-957.el7.x86_64
Found initrd image: /boot/initramfs-3.10.0-957.el7.x86_64.img

Found linux image: /boot/vmlinuz-0-rescue-f51e8a5b29294017becaa36390ba7bdd
Found initrd image: /boot/initramfs-0-rescue-f51e8a5b29294017becaa36390ba7bdd.img
done
[root@rhel7 ~]# 

Additional info:

Replacing:
GRUB_CMDLINE_LINUX="console=tty0 crashkernel=auto" console=ttyS0,115200n8 no_timer_check net.ifnames=0
by
GRUB_CMDLINE_LINUX="console=tty0 crashkernel=auto console=ttyS0,115200n8 no_timer_check net.ifnames=0"

Fix the issue, the " should be at the end of the line

Comment 2 Alan Pevec 2018-12-07 21:23:23 UTC

*** This bug has been marked as a duplicate of bug 1646976 ***

Comment 3 Tim Coote 2019-03-12 19:28:43 UTC
I think that I'm suffering from this bug, but unfortunately, I cannot get to the duplicate with my login. Is it a secret for some reason?

Comment 4 Tim Herren 2019-03-25 16:49:49 UTC
@Tim Coote

I too wasn't able to gain access to the private duplicate. Not even trough a RedHat Support Case. However they shared with me that the private duplicate has the status of "modified".

According to RH modified means: MODIFIED : This bug report has been fixed, unit tested and checked into source control by the Assigned Engineer.

This was the update I got on Feb. 13 2019. No further progress since then.


Note You need to log in before you can comment on or make changes to this bug.