Bug 1657407 - nfs-utils not a dependency to libstoragemgmt-nfs-plugin
Summary: nfs-utils not a dependency to libstoragemgmt-nfs-plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libstoragemgmt
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Tony Asleson
QA Contact: Storage QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-07 22:41 UTC by John Pittman
Modified: 2019-11-05 22:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:30:51 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3629 None None None 2019-11-05 22:30:57 UTC

Description John Pittman 2018-12-07 22:41:04 UTC
Description of problem:

After installing libstoragemgmt and libstoragemgmt-nfs-plugin, attempts to connect fail with the following error:

[root@localhost ~]# lsmcli -u nfs:// fs-export --fs 800 --exportpath /export1 --rw-host 192.168.122.120
PLUGIN_BUG(2): Unhandled exception in plug-in Data: Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/lsm/_pluginrunner.py", line 109, in run
    **msg['params'])
  File "/usr/lib/python3.6/site-packages/lsm/plugin/nfs/nfs.py", line 536, in export_fs
    efile = NFSPlugin._open_exports(readonly=False)
  File "/usr/lib/python3.6/site-packages/lsm/plugin/nfs/nfs.py", line 269, in _open_exports
    efile = open(filename, mode)
FileNotFoundError: [Errno 2] No such file or directory: '/etc/exports.d/libstoragemgmt.exports'

The error is due to the /etc/exports.d/ directory not being present.  This can be fixed by installing the nfs-utils package.  To prevent the end user from encountering this failure, install nfs-utils when the libstoragemgmt-nfs-plugin is installed.

Version-Release number of selected component (if applicable):

libstoragemgmt-1.6.2-9.el8
libstoragemgmt-nfs-plugin-1.6.2-9.el8
nfs-utils-2.3.3-7.el8.x86_64

How reproducible:
every time

Steps to Reproduce:

# yum install libstoragemgmt*
<lsmcli nfs command>


Actual results:

nfs-utils not installed automatically with libstoragemgmt-nfs-plugin

Expected results:

install nfs-utils automatically when libstoragemgmt-nfs-plugin is installed

Comment 1 Alice Mitchell 2018-12-14 10:48:31 UTC
the 'exportfs' command from that package is also required, so i have submitted a pull request that adds the relevant Requires line to the rpm spec file.

Comment 3 Jakub Krysl 2019-08-21 11:37:37 UTC
libstoragemgmt-nfs-plugin-1.8.1-2.el8.noarch.rpm requirements:
/bin/sh
/bin/sh
/usr/libexec/platform-python
libstoragemgmt-nfs-plugin-clibs = 1.8.1
*** nfs-utils ***
python(abi) = 3.6
python3-libstoragemgmt = 1.8.1
python3-libstoragemgmt = 1.8.1
python3-libstoragemgmt = 1.8.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Not nfs-utils is required for the plugins and /etc/exports.d is present.

Comment 6 errata-xmlrpc 2019-11-05 22:30:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3629


Note You need to log in before you can comment on or make changes to this bug.