Bug 1657438 - Smoke is failing on inability (permission issue) to remove old core files
Summary: Smoke is failing on inability (permission issue) to remove old core files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-08 07:43 UTC by Yaniv Kaul
Modified: 2018-12-10 03:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 03:17:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Yaniv Kaul 2018-12-08 07:43:38 UTC
Description of problem:
For example:
https://build.gluster.org/job/fedora-smoke/3503/console :

09:12:29 Please proceed with configuring, compiling, and installing.
09:12:29 rm: cannot remove '/build/install/cores/glfs_posix_rese-18323.core': Permission denied
09:12:29 rm: cannot remove '/build/install/cores/glfs_sproc0-13953.core': Permission denied
09:12:29 Build step 'Execute shell' marked build as failure

Comment 1 Nigel Babu 2018-12-10 02:51:23 UTC
This is most likely because of the TSAN job. It's messing up permission + causing machines to go down. I'm going to disable the job, fix the permission issues, and create a new machine on Rackspace with Fedora for TSAN.

Comment 2 Nigel Babu 2018-12-10 03:17:08 UTC
builder46 was the only affected builder and I've fixed up the permission issues now.


Note You need to log in before you can comment on or make changes to this bug.