Bug 165748 - Order of objects on Gnome panel mixed up after switching from 1600x1200 to 1024x768 and back
Order of objects on Gnome panel mixed up after switching from 1600x1200 to 10...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 14:44 EDT by Jan Eri
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 04:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config dump at 1600x1200 before going lowres (182.23 KB, application/octet-stream)
2005-08-18 17:28 EDT, Jan Eri
no flags Details
Config dump at at 1024x768 (182.22 KB, application/octet-stream)
2005-08-18 17:28 EDT, Jan Eri
no flags Details
Config dump at 1600x1200 after returning from lowres (182.19 KB, application/octet-stream)
2005-08-18 17:29 EDT, Jan Eri
no flags Details
This is what the panel should look like (before) (25.53 KB, image/png)
2005-08-18 17:30 EDT, Jan Eri
no flags Details
This is what the panel looked like afterwards (25.39 KB, image/png)
2005-08-18 17:32 EDT, Jan Eri
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 314235 None None None Never

  None (edit)
Description Jan Eri 2005-08-11 14:44:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
the order of the objects on the Gnome panel gets mixed up after switching from resolution 1600x1200 to resolution 1024x768 and to 1600x1200. This is quite annoying, as it takes quite some time to restore.

Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-10.2

How reproducible:
Always

Steps to Reproduce:
1. Desktop -> Preferences -> Screen Resolution = 1600x1200
I added some items to the gnome-panel during ordinary use

2. Desktop -> Preferences -> Screen Resolution = 1024x768
I did this because I was using a projector

3. Desktop -> Preferences -> Screen Resolution = 1600x1200
finished using the projector


Actual Results:  Observe that the order of the objects in the gnome panel has changed


Expected Results:  Nothing should have changed

Additional info:
Comment 1 Mark McLoughlin 2005-08-18 10:42:08 EDT
This should only happen if you change your panel config while its at the lower
resolution, I think.

Could you try and reproduce and attach the following

  - A dump of the panel config before change resolution the first time and after 
    changing back to the original resolution - use "gconftool-2 --dump 
    /apps/panel"

  - A screenshot from before and after

Thanks
Comment 2 Jan Eri 2005-08-18 15:29:46 EDT
Ok, I can try to reproduce and report. But first: is there a way I can save my
gnome-panel? It takes quite some time to get it back in shape. If not, it would
be helpful to know how to restore the default panel
Comment 3 Mark McLoughlin 2005-08-18 16:34:13 EDT
 - To restore the default panel, do

      $> gconftool-2 --recursive-unset /apps/panel

 - To save your panel config and restore it, you could do:

      $> gconftool-2 --dump /apps/panel > panel-config.dump

        [ Do your stuff ]

      $> gconftool-2 --load panel-config.dump

   You might need to re-start your panel at that point - "killall gnome-panel"
Comment 4 Jan Eri 2005-08-18 17:28:07 EDT
Created attachment 117884 [details]
Config dump at 1600x1200 before going lowres
Comment 5 Jan Eri 2005-08-18 17:28:48 EDT
Created attachment 117885 [details]
Config dump at at 1024x768
Comment 6 Jan Eri 2005-08-18 17:29:29 EDT
Created attachment 117886 [details]
Config dump at 1600x1200 after returning from lowres
Comment 7 Jan Eri 2005-08-18 17:30:27 EDT
Created attachment 117887 [details]
This is what the panel should look like (before)
Comment 8 Jan Eri 2005-08-18 17:32:15 EDT
Created attachment 117888 [details]
This is what the panel looked like afterwards
Comment 9 Jan Eri 2005-08-18 18:13:05 EDT
I should probably mention that in the sequence documented above, I did
absolutely nothing, except switching resolution and do what you asked me to.
Nothing was done to the panel while in 1024x768.
Comment 10 Mark McLoughlin 2005-08-19 05:05:01 EDT
Heh, that's actually quite funny - the problem is caused by some trickery that
is supposed to *stop* people's panels getting screwed up when they switch
resolutions.

Basically, when you switch to the lower resolution the panel all your panel
objects are squished together and the panel thinks that means you want all the
applets on the right hand side. I don't think this would happen if you'd less
things on your panel.

A diff of the before and after configs show that all applets become "right
stuck" e.g.


@@ -16,11 +16,11 @@
    launcher_location = gegl-00b540bf94.desktop
    tooltip =
    use_menu_path = false
-   panel_right_stick = false
+   panel_right_stick = true
    locked = false
    menu_path = applications:/
    object_type = launcher-object
-   position = 380
+   position = 6
   /tmp/t2/objects/object_0:
    toplevel_id = panel_0
    action_type = force-quit
@@ -31,11 +31,11 @@
    launcher_location =
    tooltip =
    use_menu_path = false
-   panel_right_stick = false
+   panel_right_stick = true
    locked = false
    menu_path = applications:/
    object_type = action-applet
-   position = 538
+   position = 4
   /tmp/t2/objects/menu_bar:
    toplevel_id = top_panel
    action_type = lock

Going to track this bug upstream, thanks for all the details.
Comment 11 Mark McLoughlin 2005-08-23 04:01:05 EDT
Okay, moved upstream now. Thanks

  http://bugzilla.gnome.org/show_bug.cgi?id=314235

Note You need to log in before you can comment on or make changes to this bug.