Bug 1657485 - in java-1.8.0-openjdk-openjfx symlink to libglassgtk2.so is missing
Summary: in java-1.8.0-openjdk-openjfx symlink to libglassgtk2.so is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1659335 (view as bug list)
Depends On:
Blocks: 1657636 1665918
TreeView+ depends on / blocked
 
Reported: 2018-12-08 20:32 UTC by Kai Hambrecht
Modified: 2019-01-22 01:34 UTC (History)
12 users (show)

Fixed In Version: java-1.8.0-openjdk-1.8.0.191.b13-0.fc29 java-1.8.0-openjdk-1.8.0.191.b13-0.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-18 02:13:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Kai Hambrecht 2018-12-08 20:32:51 UTC
Description of problem:

The package "java-1.8.0-openjdk-openjfx" provides symlinks to extra JavaFX package "openjfx". All shared libs are symlinked except for libglassgtk2.so. Running JavaFX applications will fail.

Version-Release number of selected component (if applicable):

java-1.8.0-openjdk-1.8.0.191.b12-11.fc28.x86_64
java-1.8.0-openjdk-openjfx-1.8.0.191.b12-11.fc28.x86_64
openjfx-8.0.202-2.b02.fc28.x86_64

How reproducible:

Install above listed packages, run JavaFX application (e.g. MediathekView -> https://mediathekview.de/ )

Steps to Reproduce:

run MediathekView app

Actual results:

Exception in thread "AWT-EventQueue-0" java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Can't load library: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc28.x86_64/jre/lib/amd64/libglassgtk2.so
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:267)


Expected results:

app should run without error 

Additional info:

The integration package java-1.8.0-openjdk-openjfx must also include symlink to libglassgtk2.so

Comment 1 jiri vanek 2018-12-10 12:09:32 UTC
you are right:
jdk links:
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libdecora_sse.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libglass.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libjavafx_font.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libjavafx_font_freetype.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libjavafx_font_pango.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libjavafx_iio.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libprism_common.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libprism_es2.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libprism_sw.so
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/ext/jfxrt.jar
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/javafx.properties
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/jfxswt.jar
...
 x
...
fx files:
/usr/lib/jvm/openjfx/rt/lib/amd64/libdecora_sse.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libglass.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libglassgtk2.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libjavafx_font.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libjavafx_font_freetype.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libjavafx_font_pango.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libjavafx_iio.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libprism_common.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libprism_es2.so
/usr/lib/jvm/openjfx/rt/lib/amd64/libprism_sw.so
/usr/lib/jvm/openjfx/rt/lib/ext/jfxrt.jar
/usr/lib/jvm/openjfx/rt/lib/javafx.properties
/usr/lib/jvm/openjfx/rt/lib/jfxswt.jar


The
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-11.fc29.x86_64/jre/lib/amd64/libglassgtk2.so ->
 /usr/lib/jvm/openjfx/rt/lib/amd64/libglassgtk2.so 


IS the only missing.

Comment 2 jiri vanek 2018-12-10 12:10:11 UTC
Please note, that AFAIK, openjfx is now ORPHANED and potentially security hazard.

Comment 3 jiri vanek 2018-12-10 12:12:37 UTC
Oh. Looks liek it wa already adopted! https://koji.fedoraproject.org/koji/userinfo?userID=4261  and close to latest version.
it is very likely that gtk2's glass was not in initial build

Comment 5 jiri vanek 2018-12-10 12:41:38 UTC
Feel free to verify the CI build.

Comment 6 Nicolas De Amicis 2018-12-11 07:15:39 UTC
Hi, I'm the new maintainer of the package openjfx. I did not realize that we had to change this package too. In the future if needed, I can help.

Comment 7 Severin Gehwolf 2018-12-11 09:24:43 UTC
(In reply to jiri vanek from comment #5)
> Feel free to verify the CI build.

For reference the CI build is this:
http://koji.fedoraproject.org/koji/taskinfo?taskID=31390473

Comment 8 Kai Hambrecht 2018-12-11 13:55:44 UTC
Did a mock build from above mentioned CI source rpm. Previously missing sysmlink is now included.

Comment 9 jiri vanek 2018-12-12 11:30:08 UTC
(In reply to Nicolas De Amicis from comment #6)
> Hi, I'm the new maintainer of the package openjfx. I did not realize that we
> had to change this package too. In the future if needed, I can help.

Yah! Noticed! congratulations to your bravery!

If there is some major change, just drop an echo. TYVM!

Comment 10 jiri vanek 2018-12-12 11:30:24 UTC
(In reply to Kai Hambrecht from comment #8)
> Did a mock build from above mentioned CI source rpm. Previously missing
> sysmlink is now included.

TYVM!

Comment 11 jiri vanek 2018-12-12 11:38:50 UTC
merged.

Comment 12 Alick Zhao 2018-12-13 17:37:56 UTC
Please push an update to bodhi. I'll be happy to test it out.

Comment 13 Severin Gehwolf 2018-12-14 08:28:53 UTC
*** Bug 1659335 has been marked as a duplicate of this bug. ***

Comment 14 jiri vanek 2019-01-14 14:15:50 UTC
Sorry slipped out of radar. will do today.

Comment 16 Fedora Update System 2019-01-15 09:33:30 UTC
java-1.8.0-openjdk-1.8.0.191.b13-0.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-99cdf880af

Comment 17 Fedora Update System 2019-01-15 09:33:35 UTC
java-1.8.0-openjdk-1.8.0.191.b13-0.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9625176922

Comment 18 Fedora Update System 2019-01-16 03:31:07 UTC
java-1.8.0-openjdk-1.8.0.191.b13-0.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-99cdf880af

Comment 19 Fedora Update System 2019-01-16 03:38:49 UTC
java-1.8.0-openjdk-1.8.0.191.b13-0.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9625176922

Comment 20 Nicolas De Amicis 2019-01-17 08:33:51 UTC
*** Bug 1665918 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2019-01-18 02:13:23 UTC
java-1.8.0-openjdk-1.8.0.191.b13-0.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-01-22 01:34:43 UTC
java-1.8.0-openjdk-1.8.0.191.b13-0.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.