Bug 1657579 - unable to open attachments
Summary: unable to open attachments
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Attachments/Requests
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 5.0-RH2
Assignee: Jeff Fearn 🐞
QA Contact: Rony Gong 🔥
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 02:38 UTC by Doran Moppert
Modified: 2019-04-04 10:31 UTC (History)
4 users (show)

Fixed In Version: 5.0.4.rh13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 02:13:32 UTC


Attachments (Terms of Use)

Description Doran Moppert 2018-12-10 02:38:07 UTC
Trying to view the attachment at https://bugzilla.redhat.com/show_bug.cgi?id=1650362#c16 takes me to https://bugzilla-attachments.redhat.com/attachment.cgi?id=1512142&t=<elided> where I am unable to log in with key+otp or bugzilla password.

Other prodsec members report the same (pharvey, jhebden).

Comment 1 Doran Moppert 2018-12-10 04:14:49 UTC
For those needing a workaround, python-bugzilla / pybugz can still download attachments using the xmlrpc interface.

Comment 2 Jeff Fearn 🐞 2018-12-10 04:47:06 UTC
Note the in browser feature has been turned off for now, so clicking an attachment will revert to the old download it behavior.

It appears this is a DNS related issue which is being pursued.

Comment 4 Rony Gong 🔥 2018-12-19 05:39:10 UTC
Verified on QA server

Comment 5 Rony Gong 🔥 2019-01-21 09:45:38 UTC
Verified on QA server

Comment 6 Alasdair Kergon 2019-01-26 18:33:18 UTC
*** Bug 1669734 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Fearn 🐞 2019-02-06 07:11:17 UTC
This change has been deployed to partner Bugzilla [1] for pre-release testing, if your testing reveals any issues please update this bug.

1: https://partner-bugzilla.redhat.com/

Comment 8 Jeff Fearn 🐞 2019-02-13 02:13:32 UTC
This change is now live. If there are any issues, do not reopen this bug.                                                                                                           
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.