Bug 165765 - lvchange -j is presented to user but not doc'ed
Summary: lvchange -j is presented to user but not doc'ed
Status: CLOSED DUPLICATE of bug 204997
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-11 21:27 UTC by Corey Marthaler
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 15:19:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2005-08-11 21:27:06 UTC
Description of problem:
I'm not sure what "-j" does, but it says I can use it:

lvm> lvchange
  One or more of -a, -C, -j, -m, -M, -p, -r, --refresh, --alloc, --addtag or
--deltag required

lvm> lvchange -h
  lvchange: Change the attributes of logical volume(s)

lvchange
        [-A|--autobackup y|n]
        [-a|--available [e|l]y|n]
        [--addtag Tag]
        [--alloc AllocationPolicy]
        [-C|--contiguous y|n]
        [-d|--debug]
        [--deltag Tag]
        [-f|--force]
        [-h|--help]
        [--ignorelockingfailure]
        [-M|--persistent y|n] [--major major] [--minor minor]
        [-P|--partial]
        [-p|--permission r|rw]
        [-r|--readahead ReadAheadSectors]
        [--refresh]
        [-t|--test]
        [-v|--verbose]
        [--version]
        LogicalVolume[Path] [LogicalVolume[Path]...]


lvm> lvchange -j /dev/gfs/testvol
  Invalid argument /dev/gfs/testvol
  Error during parsing of command line.
lvm> lvchange -jy /dev/gfs/testvol
  Invalid argument y
  Error during parsing of command line.
lvm> lvchange -j 1 /dev/gfs/testvol
  --major and --minor require -My

Comment 1 Milan Broz 2006-09-04 15:19:14 UTC
Option -j is shortcut for --major. 
Not implemented in lvm2 yet.
Closing this as duplicate of feature request for implementing LVM2 major number
option.

*** This bug has been marked as a duplicate of 204997 ***


Note You need to log in before you can comment on or make changes to this bug.