Bug 1657656 - traceback when getting bugzilla info
Summary: traceback when getting bugzilla info
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: did
Version: 28
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Petr Šplíchal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 08:54 UTC by Dalibor Pospíšil
Modified: 2019-01-15 03:36 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-08 02:40:45 UTC


Attachments (Terms of Use)
comment.patch (592 bytes, patch)
2018-12-10 09:13 UTC, Dalibor Pospíšil
no flags Details | Diff

Description Dalibor Pospíšil 2018-12-10 08:54:38 UTC
Description of problem:
Probably in conjunction with new bugzilla did produces a traceback. It looks like it prints all the data and then it tracebacks.

Workaround is not to include bugzilla and produce its output separately.

Version-Release number of selected component (if applicable):
did-0.9-7.fc28.noarch
did-0.11-1.fc28.noarch

How reproducible:
100%

Steps to Reproduce:
$ did --Redhat-Bugzilla last week
Status report for the week 49 (2018-12-03 to 2018-12-09).

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 Dalibor Pospisil <dapospis@redhat.com>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

* Bugs acked: 1
    * bz#1656087 A - Drop pam_tally2 module as it was deprecated in RHEL7 already

* Bugs triaged: 1
    * bz#1656087 A - Drop pam_tally2 module as it was deprecated in RHEL7 already

* Bugs graded: 1
    * bz#1656087 A - Drop pam_tally2 module as it was deprecated in RHEL7 already
Traceback (most recent call last):
  File "/usr/bin/did", line 42, in <module>
    did.cli.main()
  File "/usr/lib/python2.7/site-packages/did/cli.py", line 190, in main
    user_stats.check()
  File "/usr/lib/python2.7/site-packages/did/stats.py", line 136, in check
    stat.check()
  File "/usr/lib/python2.7/site-packages/did/stats.py", line 136, in check
    stat.check()
  File "/usr/lib/python2.7/site-packages/did/stats.py", line 79, in check
    self.fetch()
  File "/usr/lib/python2.7/site-packages/did/plugins/bugzilla.py", line 559, in fetch
    if bug.commented(self.user)]
  File "/usr/lib/python2.7/site-packages/did/plugins/bugzilla.py", line 246, in commented
    if (comment["author"] == user.email and
KeyError: u'author'

Comment 1 Dalibor Pospíšil 2018-12-10 09:13 UTC
Created attachment 1512969 [details]
comment.patch

It looks like the comment entity has renamed author to creator.

Comment 2 Jakub Heger 2018-12-10 09:38:20 UTC
Issue fixed upstream https://github.com/psss/did/issues/167

Comment 3 Petr Šplíchal 2018-12-19 08:56:45 UTC
I'll update Fedora packages with the latest changes in the coming days.

Comment 4 Fedora Update System 2018-12-29 09:36:27 UTC
did-0.12-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d8ab605b88

Comment 5 Fedora Update System 2018-12-29 09:37:00 UTC
did-0.12-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8f594492a2

Comment 6 Fedora Update System 2018-12-29 09:37:21 UTC
did-0.12-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bf75d3af14

Comment 7 Fedora Update System 2018-12-30 02:29:39 UTC
did-0.12-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8f594492a2

Comment 8 Fedora Update System 2018-12-30 03:17:18 UTC
did-0.12-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d8ab605b88

Comment 9 Fedora Update System 2018-12-30 04:03:58 UTC
did-0.12-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bf75d3af14

Comment 10 Fedora Update System 2019-01-08 02:40:45 UTC
did-0.12-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-01-08 03:54:04 UTC
did-0.12-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-01-15 03:36:22 UTC
did-0.12-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.