Bug 1657671 - Repositories does not get enabled automatically when registering/re-registering the system through Cockpit UI
Summary: Repositories does not get enabled automatically when registering/re-registeri...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Martin Pitt
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 09:17 UTC by Akash
Modified: 2018-12-10 12:27 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 12:27:53 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Akash 2018-12-10 09:17:41 UTC
Description of problem:
Repositories does not get enabled automatically when registering/re-registering the system through Cockpit UI 

Version-Release number of selected component (if applicable):
[root@rhel-beta ~]# rpm -qa | grep -i cockpit
cockpit-packagekit-180-1+as.el8.noarch
cockpit-180-1.el8.x86_64
cockpit-bridge-180-1.el8.x86_64
subscription-manager-cockpit-1.23.8-1.el8.noarch
cockpit-ws-180-1.el8.x86_64
cockpit-system-180-1.el8.noarch

subscription-manager-1.23.8-1.el8.x86_64
subscription-manager-rhsm-certificates-1.23.8-1.el8.x86_64
python3-subscription-manager-rhsm-1.23.8-1.el8.x86_64
subscription-manager-cockpit-1.23.8-1.el8.noarch
dnf-plugin-subscription-manager-1.23.8-1.el8.x86_64


How reproducible:


Steps to Reproduce:
1. Install RHEL 8.0 Beta
2. Install and Configure Cockpit through firewalld for accessing the Cockpit UI
3. Unregister the system via 'Subscriptions' and try to register it again in Cockpit UI

Actual results:
# yum repolist 
Updating Subscription Management repositories.
Updating Subscription Management repositories.


Expected results:
# yum repolist 
Updating Subscription Management repositories.
Updating Subscription Management repositories.
Red Hat Enterprise Linux 8 for x86_64 - AppStream Beta (RPMs)                                                                                                                                                 578 kB/s | 6.7 MB     00:11    
Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs)                                                                                                                                                    299 kB/s | 2.7 MB     00:09    
Last metadata expiration check: 0:00:01 ago on Mon 10 Dec 2018 02:33:16 PM IST.
repo id                                                                                                 repo name                                                                                                                       status
rhel-8-for-x86_64-appstream-beta-rpms                                                                   Red Hat Enterprise Linux 8 for x86_64 - AppStream Beta (RPMs)                                                                   4,594
rhel-8-for-x86_64-baseos-beta-rpms                                                                      Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs)                                                                      1,686


Additional info:
Due to this issue, system will not be able to fetch the packages & 'packagekit' daemon crashes on the initial run.


Note You need to log in before you can comment on or make changes to this bug.