Bug 1657752 - [RFE] Search box should be included on the services page
Summary: [RFE] Search box should be included on the services page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: 8.1
Assignee: Martin Pitt
QA Contact: qe-baseos-daemons
Vendula Ferschmannova
URL:
Whiteboard:
Depends On: 1678933
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 11:25 UTC by Shivam Gupta
Modified: 2019-11-05 22:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
.Adding a search box in the Services page The Services page now has a search box for filtering services by: * Name * Description * State In addition, service states have been merged into one list. The switcher buttons at the top of the page have also been changed to tabs to improve user experience of the *Services* page.
Clone Of:
Environment:
Last Closed: 2019-11-05 22:03:19 UTC
Type: Enhancement
Target Upstream Version:


Attachments (Terms of Use)
search box not included in the service tab (93.52 KB, image/png)
2018-12-10 11:25 UTC, Shivam Gupta
no flags Details


Links
System ID Priority Status Summary Last Updated
Github cockpit-project cockpit issues 10010 None None None 2018-12-11 13:42:39 UTC
Red Hat Product Errata RHBA-2019:3518 None None None 2019-11-05 22:03:28 UTC

Description Shivam Gupta 2018-12-10 11:25:31 UTC
Created attachment 1513028 [details]
search box not included in the service tab

Description of problem: search box should be included inside the "http://localhost:9090/system/services" under cockpit to filter out the services using their names.


Version-Release number of selected component (if applicable):Version 180. 


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:search box is not currently included in the services tab. 


Expected results: search box should be present at the top of the services tab inside cockpit so that user can easily filter out the particular service from the huge list of services. 


Additional info:

Comment 1 Shivam Gupta 2018-12-10 11:29:19 UTC
User need to scroll down and manually search for each and every service which is time consuming process in case of a production server where more services needs to be run at a particular instant of time.

Comment 2 Martin Pitt 2019-03-11 11:06:13 UTC
This landed in 189. We plan to rebase Cockpit for 8.1.

Comment 9 errata-xmlrpc 2019-11-05 22:03:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3518


Note You need to log in before you can comment on or make changes to this bug.