Bug 1657755 - dvipdfmx links to an unexistent file
Summary: dvipdfmx links to an unexistent file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 29
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1657754 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 11:38 UTC by Marco Guazzone
Modified: 2018-12-16 04:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-16 04:22:17 UTC


Attachments (Terms of Use)

Description Marco Guazzone 2018-12-10 11:38:49 UTC
Description of problem:

The command "dvipdfmx" does not work since it is a symbolic link to "xdvipdfmx" which does not exist in my file system.

Version-Release number of selected component (if applicable):

texlive-dvipdfmx-20180414-28.fc29.x86_64


How reproducible:

Simply install the texlive-dvipdfmx package


Steps to Reproduce:
1. sudo dnf install texlive-dvipdfmx
2. cd/usr/bin
3. ls dvipdfmx


Actual results:

The third step produces the following output:

   lrwxrwxrwx. 1 root root 9 Nov 26 19:22 dvipdfmx -> xdvipdfmx

where the symbolic link is broken.

As a consequence, the "dvipdfmx" command as well as the "dvipdfm", "ebb", "extracbb" commands) do not work.


Expected results:

"xdvipdfmx" must exist in the file system


Additional info:

I have tried to remove the above broken links and to reinstall the package:
  1. cd /usr/bin
  2. sudo rm dvipdfm dvipdfmx ebb extractbb
  3. sudo dnf reinstall texlive-dvipdfmx
without any success: the third step recreates the above broken links.

Comment 1 Marco Guazzone 2018-12-11 20:25:43 UTC
To solve this issue, you need to install:
  texlive-xetex

Thanks to Jon Ingason (see discussion:
  https://lists.fedoraproject.org/archives/list/users@lists.fedoraproject.org/thread/WG27LAKHCBQC7OOZK4SYS2CAPFQF2HFN/

I am leaving this bug open since, in my opinion, package texlive-dvipdfmx should have as dependency the package texlive-xetex.

Comment 2 Fedora Update System 2018-12-13 18:45:37 UTC
texlive-base-20180414-30.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f426779bb4

Comment 3 Tom "spot" Callaway 2018-12-14 14:06:40 UTC
*** Bug 1657754 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2018-12-16 04:22:17 UTC
texlive-base-20180414-30.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.