Bug 1657756 - [RFE] need to add an filter button for accessing a particular log file inside cockpit.
Summary: [RFE] need to add an filter button for accessing a particular log file inside...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: 8.1
Assignee: Martin Pitt
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 11:41 UTC by Shivam Gupta
Modified: 2020-11-14 10:57 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:03:19 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github cockpit-project cockpit issues 1535 0 None None None 2018-12-11 14:27:18 UTC
Red Hat Product Errata RHBA-2019:3518 0 None None None 2019-11-05 22:03:28 UTC

Description Shivam Gupta 2018-12-10 11:41:58 UTC
Description of problem: needs to add an additional filter option in "http://localhost:9090/system/logs" tab inside cockpit so that user can filter out the log file of a particular service. If need to monitor only particular log eg.secure/httpd/cron log then it is necessary to filter out from the list of logs.


Version-Release number of selected component (if applicable):Version 180. 


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: only two filters are available inside log section which only filters logs  based on their date and severity. user cannot filter out a particular log file.


Expected results: A additional filter needs to be added under logs section inside cockpit which filter logs based on their types ex. secure/cron/messages.


Additional info:

Comment 1 Martin Pitt 2018-12-11 14:27:18 UTC
You can already see the logs for a specific service on the "Services" page.

Comment 2 Shivam Gupta 2018-12-12 05:08:50 UTC
Logs at the services page can only list 10 lines of whole log file and these 10 lines are only real time log. Past logs cannot be viewed at services page.

Comment 3 Martin Pitt 2019-03-25 06:47:29 UTC
Such a filter was added in release 190.

Comment 7 errata-xmlrpc 2019-11-05 22:03:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3518


Note You need to log in before you can comment on or make changes to this bug.