Bug 1657774 - IPA uninstallation breaks because of empty arg in authselect
Summary: IPA uninstallation breaks because of empty arg in authselect
Keywords:
Status: CLOSED DUPLICATE of bug 1654291
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: authselect
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Pavel Březina
QA Contact: Steeve Goveas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 12:21 UTC by msiddiqu
Modified: 2018-12-10 12:37 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 12:37:26 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description msiddiqu 2018-12-10 12:21:53 UTC
Description of problem:
IPA Server uninstallation breaks because of empty arg in authselect. This is causing server-install test cases to skip on jenkins and beaker.

Version-Release number of selected component (if applicable):
# cat /etc/redhat-release
Red Hat Enterprise Linux release 8.0 Beta (Ootpa)
# rpm -qa | grep authselect
authselect-libs-1.0-9.el8.x86_64
authselect-1.0-9.el8.x86_64

Observed in Build : RHEL-8.0-20181209.n.0 BaseOS x86_64

How reproducible: Always on the above mentioned build

Steps to Reproduce:
1. Install IPA server
2. Uninstall IPA server

Actual results:

# /usr/bin/authselect select sssd '', '--force'
Backup stored at /var/lib/authselect/backups/2018-12-10-11-23-19.2D4CV4
[error] Unknown profile feature [,]
[error] Unable to activate profile [sssd] [22]: Invalid argument
Unable to activate profile [22]: Invalid argument

Expected results:

# /usr/bin/authselect select sssd '', '--force'
Backup stored at /var/lib/authselect/backups/2018-12-10-11-24-54.6cKcG1
Profile "sssd" was selected.
The following nsswitch maps are overwritten by the profile:
- passwd
- group
- netgroup
- automount
- services

Make sure that SSSD service is configured and enabled. See SSSD documentation for more information.

Expected result is observed in: 
# cat /etc/redhat-release 
Red Hat Enterprise Linux release 8.0 Beta (Ootpa)
Observed in build : RHEL-8.0-20181129.n.0 BaseOS x86_64

# rpm -qa | grep authselect
authselect-libs-1.0-6.el8.x86_64
authselect-1.0-6.el8.x86_64

Comment 3 msiddiqu 2018-12-10 12:37:26 UTC

*** This bug has been marked as a duplicate of bug 1654291 ***


Note You need to log in before you can comment on or make changes to this bug.