Bug 1657854 - remove userland support for deprecated KLIPS IPsec stack support [NEEDINFO]
Summary: remove userland support for deprecated KLIPS IPsec stack support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libreswan
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Paul Wouters
QA Contact: Jaroslav Aster
Ioanna Gkioka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 15:34 UTC by Paul Wouters
Modified: 2019-06-14 01:45 UTC (History)
2 users (show)

Fixed In Version: 3.27-4
Doc Type: Removed functionality
Doc Text:
.KLIPS has been removed from *Libreswan* In Red Hat Enterprise Linux 8, support for Kernel IP Security (KLIPS) IPsec stack has been removed from *Libreswan*.
Clone Of:
Environment:
Last Closed: 2019-06-14 01:45:09 UTC
Type: Bug
igkioka: needinfo? (pwouters)


Attachments (Terms of Use)

Description Paul Wouters 2018-12-10 15:34:53 UTC
upstream libreswan supports an alternative KLIPS IPsec stack. This stack was never supported in RHEL. But userland was built with support for this stack so customer who wanted to use the alternative IPsec kernel stack could do so without recompiling the libreswan userland.

Upstream is disabling KLIPS support per default and will remove it entirely soon.

Therefor, remove the userland support from libreswan in RHEL8. This should affect no regular users of libreswan with RHEL.


Note You need to log in before you can comment on or make changes to this bug.