Bug 1657928 - libvirt uninstallable on 32 bit arches: nothing provides librados.so.2 needed by libvirt-daemon-driver-storage-rbd-4.10.0-1.fc30.i686
Summary: libvirt uninstallable on 32 bit arches: nothing provides librados.so.2 needed...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2018-12-10 18:21 UTC by Richard W.M. Jones
Modified: 2018-12-10 19:17 UTC (History)
8 users (show)

Fixed In Version: libvirt-4.10.0-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 19:17:22 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2018-12-10 18:21:51 UTC
Description of problem:

DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem: package libguestfs-1:1.39.11-2.fc30.i686 requires libvirt-daemon-kvm >= 0.10.2-3, but none of the providers can be installed
DEBUG util.py:439:    - package libvirt-daemon-kvm-4.10.0-1.fc30.i686 requires libvirt-daemon-driver-storage = 4.10.0-1.fc30, but none of the providers can be installed
DEBUG util.py:439:    - package libguestfs-devel-1:1.39.11-2.fc30.i686 requires libguestfs.so.0, but none of the providers can be installed
DEBUG util.py:439:    - package libvirt-daemon-driver-storage-4.10.0-1.fc30.i686 requires libvirt-daemon-driver-storage-rbd = 4.10.0-1.fc30, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides librados.so.2 needed by libvirt-daemon-driver-storage-rbd-4.10.0-1.fc30.i686
DEBUG util.py:577:  Child return code was: 1

This is not really a bug in libvirt because ceph has removed
client support, see:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/XCQIMO3W3D5XGHQHBVVIBUBPIXKJJJWL/#ZY76AVZ5CPBYLKDIKPX5PQLJNJYXPUS4

We should probably remove the ceph dep on 32 bit arches.

Version-Release number of selected component (if applicable):

libvirt 4.10.0-1.fc30.i686 & armv7

How reproducible:

100%

Steps to Reproduce:
1. Install libvirt on Rawhide on 32 bit arches.


Note You need to log in before you can comment on or make changes to this bug.