Bug 165797 - No package owns /
No package owns /
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: filesystem (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 08:14 EDT by Andrew Benham
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 02:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filesystem.spec (7.83 KB, text/plain)
2005-08-19 05:07 EDT, Andrew Benham
no flags Details
filesystem-2.3.4-1.i386.rpm (18.39 KB, application/x-rpm)
2005-08-19 05:09 EDT, Andrew Benham
no flags Details

  None (edit)
Description Andrew Benham 2005-08-12 08:14:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The %files list in filesystem.spec does not include '/'

This means that on a RedHat system no package owns '/':

$ rpm -qf /
file / is not owned by any package

Surely the filesystem package should own / as it owns its subdirectories ?

The problem we have is when building our own packages, our rule is that every
file/directory must be owned by a package. When we build one of our packages,
and scan through our build root (comparing it with the real file system), we
discover that / isn't owned by a package, so it must be a new directory created
by this package, and so should be owned by this package.

After a while, all of our own packages are the owners of /, which causes even
more problems.

Now we could make / a special case, but the right answer seems to be that the
filesystem package should own /

In the worst scenario, a script to tidy a machine might delete directories which
aren't owned by any package, and could therefore delete /

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Linux
2. Do "rpm -qf /"

  

Actual Results:  file / is not owned by any package

Expected Results:  filesystem-<version>-<release>

Additional info:
Comment 1 Bill Nottingham 2005-08-19 02:16:58 EDT
This isn't possible with RPM.
Comment 2 Andrew Benham 2005-08-19 05:07:30 EDT
Created attachment 117902 [details]
filesystem.spec
Comment 3 Andrew Benham 2005-08-19 05:09:17 EDT
Created attachment 117903 [details]
filesystem-2.3.4-1.i386.rpm

So, this package couldn't have been built from the attached spec file then ??
Comment 4 Bill Nottingham 2005-08-19 17:20:57 EDT
Hah, so it does work now. It didn't always work.

Thanks for the report. It will be fixed in the Fedora Core development tree, and
will be included in RHEL 5.

Note You need to log in before you can comment on or make changes to this bug.