Bug 1658015 - SELinux is preventing sss_cache from 'create' accesses on the file config.ldb.
Summary: SELinux is preventing sss_cache from 'create' accesses on the file config.ldb.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fa5ed708c1913d0b501464a08db...
: 1659310 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 03:06 UTC by chiguy1256
Modified: 2019-01-09 21:55 UTC (History)
7 users (show)

Fixed In Version: selinux-policy-3.14.1-50.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-09 21:53:40 UTC
Type: ---


Attachments (Terms of Use)

Description chiguy1256 2018-12-11 03:06:13 UTC
Description of problem:
SELinux is preventing sss_cache from 'create' accesses on the file config.ldb.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sss_cache should be allowed create access on the config.ldb file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sss_cache' --raw | audit2allow -M my-ssscache
# semodule -X 300 -i my-ssscache.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:groupadd_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:sssd_var_lib_t:s0
Target Objects                config.ldb [ file ]
Source                        sss_cache
Source Path                   sss_cache
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-48.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.6-200.fc28.x86_64 #1 SMP Sun
                              Dec 2 18:03:32 UTC 2018 x86_64 x86_64
Alert Count                   2
First Seen                    2018-12-10 22:04:44 EST
Last Seen                     2018-12-10 22:04:44 EST
Local ID                      6a91f370-4cb0-4f9a-ba72-1c9a372e6beb

Raw Audit Messages
type=AVC msg=audit(1544497484.892:272): avc:  denied  { create } for  pid=4800 comm="sss_cache" name="config.ldb" scontext=unconfined_u:unconfined_r:groupadd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:sssd_var_lib_t:s0 tclass=file permissive=0


Hash: sss_cache,groupadd_t,sssd_var_lib_t,file,create

Version-Release number of selected component:
selinux-policy-3.14.1-48.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.19.6-200.fc28.x86_64
type:           libreport

Comment 1 Lukas Slebodnik 2019-01-09 21:55:05 UTC
*** Bug 1659310 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.